aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gettext
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-29 13:54:25 +1030
committerEric Bénard <eric@eukrea.com>2010-11-29 11:31:57 +0100
commit471555d4ac810758d6c776101a3eb8c2dbbee225 (patch)
tree46b2fece147c888b37aba3692fdc4a5c50e50190 /recipes/gettext
parentcdb73aacf04633d46ef05e27012dfa85b9b967a4 (diff)
downloadopenembedded-471555d4ac810758d6c776101a3eb8c2dbbee225.tar.gz
gettext_0.18.bb: Fix build when uclibc lacks large file support.
mipsel-oe-linux-uclibc-libtool: compile: mipsel-oe-linux-uclibc-gcc -march=mips32 -std=gnu99 -DHAVE_CONFIG_H -DEXEEXT=\"\" -DEXEEXT=\"\" -DEXEEXT=\"\" -I. -I.. -I../intl -I../intl -I.. -I.. -DDEPENDS_ON_LIBICONV=1 -DDEPENDS_ON_LIBINTL=1 -DLIBXML_STATIC -I../intl -I./libcroco -isystem/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -I/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -isystem/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -c libxml/DOCBparser.c -fPIC -DPIC -o libxml/.libs/libxml_rpl_la-DOCBparser.o In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:28:0, from ./stdio.h:35, from libxml/libxml.h:36, from libxml/DOCBparser.c:14: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/features.h:216:5: error: #error It appears you have defined _FILE_OFFSET_BITS=64. Unfortunately, uClibc was built without large file support enabled. In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:72:0, from ./stdio.h:35, from libxml/libxml.h:36, from libxml/DOCBparser.c:14: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/bits/uClibc_stdio.h:61:2: error: #error Sorry... uClibc was built without large file support! In file included from ./stdio.h:35:0, from libxml/libxml.h:36, from libxml/DOCBparser.c:14: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:83:26: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'fpos_t' In file included from ./stdio.h:35:0, from libxml/libxml.h:36, from libxml/DOCBparser.c:14: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:719:12: error: expected declaration specifiers or '...' before 'fpos_t' /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:721:12: error: expected ';', ',' or ')' before '*' token make[4]: *** [libxml/libxml_rpl_la-DOCBparser.lo] Error 1 Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/gettext')
-rw-r--r--recipes/gettext/gettext_0.18.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/gettext/gettext_0.18.bb b/recipes/gettext/gettext_0.18.bb
index 5ad6459630..d27fad8f55 100644
--- a/recipes/gettext/gettext_0.18.bb
+++ b/recipes/gettext/gettext_0.18.bb
@@ -19,6 +19,9 @@ SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
SRC_URI_append_libc-uclibc = " file://gettext-error_print_progname.patch"
+nolargefile = "${@base_contains('DISTRO_FEATURES', 'largefile', '', '-DNO_LARGEFILE_SOURCE', d)}"
+EXTRA_OEMAKE_append_libc-uclibc = "'CFLAGS=${CFLAGS} ${nolargefile}'"
+
PARALLEL_MAKE = ""
inherit autotools