aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gftp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gftp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gftp')
-rw-r--r--recipes/gftp/gftp/configure.patch31
-rw-r--r--recipes/gftp/gftp_2.0.18.bb18
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes/gftp/gftp/configure.patch b/recipes/gftp/gftp/configure.patch
new file mode 100644
index 0000000000..362ce963d2
--- /dev/null
+++ b/recipes/gftp/gftp/configure.patch
@@ -0,0 +1,31 @@
+--- gftp-2.0.18rc1/configure.in 2004-11-09 19:32:01.000000000 -0700
++++ gftp-2.0.18rc1.new/configure.in 2005-01-04 15:04:31.297074928 -0700
+@@ -41,7 +41,8 @@
+ AM_C_PROTOTYPES
+ AC_C_CONST
+ AC_C_INLINE
+-AC_INTL_PRINTF
++
++AC_DEFINE(HAVE_INTL_PRINTF,1,Define if printf supports %'ld)
+
+ AM_MAINTAINER_MODE
+
+@@ -79,7 +80,7 @@
+ fi
+
+ if test "x$GFTP_TEXT" = "x" -a $found_glib20 = 0 ; then
+- AM_PATH_GLIB(1.2.3, , AC_MSG_ERROR(gFTP needs GLIB 1.2.3 or higher))
++ AC_MSG_ERROR(gFTP needs GLIB 2.0 or higher)
+ fi
+
+ EXTRA_LIBS=""
+@@ -195,8 +196,7 @@
+ fi
+
+ if test "x$GFTP_GTK" = "x" ; then
+- AM_PATH_GTK(1.2.3, GFTP_GTK=gftp-gtk, AC_MSG_WARN(gFTP needs GTK+ 1.2.3 or higher for the graphical version. Only building the text version))
+- GTHREAD_LIBS="-lgthread"
++ AC_MSG_ERROR(gFTP needs GTK 2.0 or higher)
+ else
+ GTHREAD_LIBS="-lgthread-2.0"
+ fi
diff --git a/recipes/gftp/gftp_2.0.18.bb b/recipes/gftp/gftp_2.0.18.bb
new file mode 100644
index 0000000000..f5705b1357
--- /dev/null
+++ b/recipes/gftp/gftp_2.0.18.bb
@@ -0,0 +1,18 @@
+# gftp OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Free multithreaded file transfer client (FTP/HTTP/SSH)."
+HOMEPAGE="http://www.gftp.org/"
+SECTION = "x11/network"
+LICENSE="GPL"
+PR = "r1"
+
+SRC_URI="http://www.gftp.org/gftp-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+DEPENDS="gtk+ openssl"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-textport"