aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/giac
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/giac
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/giac')
-rw-r--r--recipes/giac/giac_0.5.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/giac/giac_0.5.0.bb b/recipes/giac/giac_0.5.0.bb
new file mode 100644
index 0000000000..36df3c22b7
--- /dev/null
+++ b/recipes/giac/giac_0.5.0.bb
@@ -0,0 +1,38 @@
+SECTION = "console/utils"
+DESCRIPTION = "A free computer algebra system"
+HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk gmp mpfr gsl"
+# ntl pari"
+
+SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-${PV}.tar.gz"
+
+inherit autotools
+
+PACKAGES += " lib${PN}"
+FILES_${PN} = "${bindir} \
+ ${datadir}/${PN}"
+FILES_lib${PN} = "${libdir}"
+
+# breaks the build...
+#EXTRA_OECONF = "--enable-debug=no"
+
+# skip autoreconf for now (fails due to improper local macros)
+do_configure() {
+ oe_runconf
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+
+ # put the docs where they belong
+ # might need further investigation in case giac needs
+ # them in the original place
+ install -d ${D}${docdir}
+ mv ${D}${datadir}/${PN}/doc ${D}${docdir}/${PN}
+}