aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gimp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gimp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gimp')
-rw-r--r--recipes/gimp/babl_svn.bb23
-rw-r--r--recipes/gimp/files/configure-libwmf.patch21
-rw-r--r--recipes/gimp/gegl/gegl-resilience.patch11
-rw-r--r--recipes/gimp/gegl_svn.bb26
-rw-r--r--recipes/gimp/gimp.inc47
-rw-r--r--recipes/gimp/gimp_2.2.10.bb4
-rw-r--r--recipes/gimp/gimp_2.3.10.bb3
-rw-r--r--recipes/gimp/gimp_2.3.19.bb2
-rw-r--r--recipes/gimp/gimp_2.3.7.bb2
-rw-r--r--recipes/gimp/gimp_2.3.8.bb2
-rw-r--r--recipes/gimp/gimp_2.4.0.bb5
-rw-r--r--recipes/gimp/gimp_2.5.2.bb13
-rw-r--r--recipes/gimp/gimp_2.6.0.bb8
-rw-r--r--recipes/gimp/gimp_2.6.3.bb8
14 files changed, 175 insertions, 0 deletions
diff --git a/recipes/gimp/babl_svn.bb b/recipes/gimp/babl_svn.bb
new file mode 100644
index 0000000000..332595ee6b
--- /dev/null
+++ b/recipes/gimp/babl_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Babl is a dynamic, any to any, pixel format conversion library."
+LICENSE = "LGPL"
+
+SRCREV = "349"
+PV = "0.0.23+svnr${SRCREV}"
+PR = "r1"
+PE = "1"
+
+inherit gnome
+
+SRC_URI = "svn://svn.gnome.org/svn/${PN};module=trunk"
+
+S = "${WORKDIR}/trunk"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+FILES_${PN} += "${libdir}/babl-0.0/"
+FILES_${PN}-dbg += "${libdir}/babl-0.0/.debug/"
+
+
diff --git a/recipes/gimp/files/configure-libwmf.patch b/recipes/gimp/files/configure-libwmf.patch
new file mode 100644
index 0000000000..ca3697cfa2
--- /dev/null
+++ b/recipes/gimp/files/configure-libwmf.patch
@@ -0,0 +1,21 @@
+--- gimp-2.3.8/configure.in.orig 2006-05-31 10:16:40.000000000 +0100
++++ gimp-2.3.8/configure.in 2006-05-31 10:18:56.000000000 +0100
+@@ -1342,7 +1342,10 @@
+ # Check for libwmf2
+ ###################
+
++AC_ARG_WITH(libwmf, [ --without-libwmf build without libwmf support])
++
+ have_libwmf=no
++if test "x$with_libwmf" != xno; then
+ AC_PATH_PROG(WMF_CONFIG, libwmf-config, no)
+ if test "x$WMF_CONFIG" != "xno" ; then
+ have_libwmf=yes
+@@ -1359,6 +1362,7 @@
+ else
+ have_libwmf="no (libwmf not found)"
+ fi
++fi
+ AC_SUBST(LIBWMF)
+ AC_SUBST(WMF_CFLAGS)
+
diff --git a/recipes/gimp/gegl/gegl-resilience.patch b/recipes/gimp/gegl/gegl-resilience.patch
new file mode 100644
index 0000000000..0e35dd50f6
--- /dev/null
+++ b/recipes/gimp/gegl/gegl-resilience.patch
@@ -0,0 +1,11 @@
+--- trunk/operations/external/ff-load.c 2008-12-20 13:37:05.000000000 -0800
++++ trunk/operations/external/ff-load.c 2008-12-20 13:37:22.000000000 -0800
+@@ -278,7 +278,7 @@
+ p->enc = p->video_st->codec;
+ p->codec = avcodec_find_decoder (p->enc->codec_id);
+
+- p->enc->error_resilience = 2;
++ p->enc->error_recognition = 2;
+ p->enc->error_concealment = 3;
+ p->enc->workaround_bugs = FF_BUG_AUTODETECT;
+
diff --git a/recipes/gimp/gegl_svn.bb b/recipes/gimp/gegl_svn.bb
new file mode 100644
index 0000000000..7f49e785ac
--- /dev/null
+++ b/recipes/gimp/gegl_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GEGL (Generic Graphics Library) is a graph based image processing framework."
+LICENSE = "LGPL"
+DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl"
+
+SRCREV = "2543"
+PV = "0.0.19+svnr${SRCREV}"
+PE = "1"
+PR = "r1"
+
+inherit gnome
+
+SRC_URI = "svn://svn.gnome.org/svn/${PN};module=trunk \
+ file://gegl-resilience.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--disable-docs "
+
+FILES_${PN} += "${libdir}/gegl-0.0"
+FILES_${PN}-dbg += "${libdir}/gegl-0.0/.debug"
+
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/gimp/gimp.inc b/recipes/gimp/gimp.inc
new file mode 100644
index 0000000000..2894582a8e
--- /dev/null
+++ b/recipes/gimp/gimp.inc
@@ -0,0 +1,47 @@
+DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
+HOMEPAGE = "http://www.gimp.org"
+SECTION = "x11/graphics"
+LICENSE = "GPL"
+
+DEPENDS = "sed-native gdk-pixbuf-csource-native libart-lgpl gtk+ jpeg libpng libexif tiff"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
+ file://configure-libwmf.patch;patch=1"
+
+inherit gnome
+
+FILES_gimp-dbg =+ "${libdir}/gimp/2.0/modules/.debug \
+ ${libdir}/gimp/2.0/plug-ins/.debug"
+
+#Don't laugh, this just builds a threaded gimp
+EXTRA_OECONF = " --disable-gtktest \
+ --disable-print \
+ --disable-python \
+ --enable-mp \
+ --without-libwmf"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+ find ${S} -name Makefile | xargs sed -i s:'file-wmf$(EXEEXT)':'':g
+}
+
+
+do_stage() {
+ autotools_stage_all
+}
+
+python populate_packages_prepend () {
+ cv_libdir = bb.data.expand('${libdir}', d)
+ do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'GIMP %s library', extra_depends='', allow_links=True)
+}
+
+FILES_${PN} = "${bindir} ${sysconfdir} ${datadir}/gimp* ${libdir}/gimp* \
+ ${datadir}/applications \
+ ${datadir}/icons \
+ ${datadir}/mime-info \
+ ${datadir}/application-registry "
+
+FILES_${PN}-dbg += "${libdir}/gimp/2.0/plug-ins/.debug \
+ ${libdir}/gimp/2.0/modules/.debug"
+
diff --git a/recipes/gimp/gimp_2.2.10.bb b/recipes/gimp/gimp_2.2.10.bb
new file mode 100644
index 0000000000..3719e2d5e5
--- /dev/null
+++ b/recipes/gimp/gimp_2.2.10.bb
@@ -0,0 +1,4 @@
+require gimp.inc
+PR = "r1"
+
+
diff --git a/recipes/gimp/gimp_2.3.10.bb b/recipes/gimp/gimp_2.3.10.bb
new file mode 100644
index 0000000000..b06687c06d
--- /dev/null
+++ b/recipes/gimp/gimp_2.3.10.bb
@@ -0,0 +1,3 @@
+require gimp.inc
+PR = "r3"
+
diff --git a/recipes/gimp/gimp_2.3.19.bb b/recipes/gimp/gimp_2.3.19.bb
new file mode 100644
index 0000000000..64d8d30e3a
--- /dev/null
+++ b/recipes/gimp/gimp_2.3.19.bb
@@ -0,0 +1,2 @@
+require gimp.inc
+
diff --git a/recipes/gimp/gimp_2.3.7.bb b/recipes/gimp/gimp_2.3.7.bb
new file mode 100644
index 0000000000..7e72e74695
--- /dev/null
+++ b/recipes/gimp/gimp_2.3.7.bb
@@ -0,0 +1,2 @@
+require gimp.inc
+PR = "r1"
diff --git a/recipes/gimp/gimp_2.3.8.bb b/recipes/gimp/gimp_2.3.8.bb
new file mode 100644
index 0000000000..7e72e74695
--- /dev/null
+++ b/recipes/gimp/gimp_2.3.8.bb
@@ -0,0 +1,2 @@
+require gimp.inc
+PR = "r1"
diff --git a/recipes/gimp/gimp_2.4.0.bb b/recipes/gimp/gimp_2.4.0.bb
new file mode 100644
index 0000000000..74bfde0661
--- /dev/null
+++ b/recipes/gimp/gimp_2.4.0.bb
@@ -0,0 +1,5 @@
+require gimp.inc
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.4/gimp-${PV}.tar.bz2 \
+ file://configure-libwmf.patch;patch=1"
+
diff --git a/recipes/gimp/gimp_2.5.2.bb b/recipes/gimp/gimp_2.5.2.bb
new file mode 100644
index 0000000000..18a12b1770
--- /dev/null
+++ b/recipes/gimp/gimp_2.5.2.bb
@@ -0,0 +1,13 @@
+require gimp.inc
+
+DEPENDS += "lcms gegl hal"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.5/gimp-${PV}.tar.bz2 \
+ "
+
+do_compile_prepend() {
+ for i in ca de fr ja oc ru sv; do
+ echo > ${S}/po/$i.po
+ done
+}
+
diff --git a/recipes/gimp/gimp_2.6.0.bb b/recipes/gimp/gimp_2.6.0.bb
new file mode 100644
index 0000000000..8470b6d5a8
--- /dev/null
+++ b/recipes/gimp/gimp_2.6.0.bb
@@ -0,0 +1,8 @@
+require gimp.inc
+
+DEPENDS += "lcms gegl hal"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.6/gimp-${PV}.tar.bz2 \
+ "
+
+
diff --git a/recipes/gimp/gimp_2.6.3.bb b/recipes/gimp/gimp_2.6.3.bb
new file mode 100644
index 0000000000..8470b6d5a8
--- /dev/null
+++ b/recipes/gimp/gimp_2.6.3.bb
@@ -0,0 +1,8 @@
+require gimp.inc
+
+DEPENDS += "lcms gegl hal"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.6/gimp-${PV}.tar.bz2 \
+ "
+
+