aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/glib-1.2/glib-1.2_1.2.10.bb
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-09-08 01:43:51 +0000
committerTom Rini <tom_rini@mentor.com>2010-09-30 14:05:23 -0700
commit44af05077f455f5b76cf76eb41dcc62a51de7582 (patch)
treed68370c53356698904772153e02bc2adee09de7b /recipes/glib-1.2/glib-1.2_1.2.10.bb
parentccc23f16dc039cb9f7fee5425846c2a21b2a36f7 (diff)
downloadopenembedded-44af05077f455f5b76cf76eb41dcc62a51de7582.tar.gz
glib-1.2: merged native and non-native recipes
* removed the glib-1.2-native_1.2.10.bb file * added NATIVE_INSTALL_WORKS = "1" * added BBCLASSEXTEND = "native" * converted do_stage of native recipe to do_install_virtclass-native in the combined recipe * added DEPENDS_pn-glib-1.2 += "glib-1.2-native", per Vitus' suggestion * added gettext in inherit because it was needed by the native recipes * bumped PR Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/glib-1.2/glib-1.2_1.2.10.bb')
-rw-r--r--recipes/glib-1.2/glib-1.2_1.2.10.bb21
1 files changed, 18 insertions, 3 deletions
diff --git a/recipes/glib-1.2/glib-1.2_1.2.10.bb b/recipes/glib-1.2/glib-1.2_1.2.10.bb
index 72ee8264c2..22e044d615 100644
--- a/recipes/glib-1.2/glib-1.2_1.2.10.bb
+++ b/recipes/glib-1.2/glib-1.2_1.2.10.bb
@@ -3,8 +3,8 @@ provide support for old glib 1.2 based applications"
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "LGPL"
-DEPENDS = "glib-1.2-native"
-PR = "r4"
+DEPENDS_pn-glib-1.2 += "glib-1.2-native"
+PR = "r5"
LEAD_SONAME = "libglib-1.2.*"
@@ -22,7 +22,7 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v1.2/glib-${PV}.tar.gz \
S = "${WORKDIR}/glib-${PV}"
-inherit autotools pkgconfig binconfig
+inherit autotools pkgconfig binconfig gettext
acpaths = ""
do_configure_prepend () {
@@ -31,6 +31,17 @@ do_configure_prepend () {
rm -f ltconfig acinclude.m4 libtool ltmain.sh
}
+do_install_virtclass-native () {
+ oe_libinstall -so libglib ${D}${libdir}
+ oe_libinstall -so -C gmodule libgmodule ${D}${libdir}
+ oe_libinstall -so -C gthread libgthread ${D}${libdir}
+ autotools_do_install
+ install -d ${D}${includedir}/glib-1.2
+ install -m 0644 glibconfig.h glib.h ${D}${includedir}/glib-1.2/
+ install -d ${D}${datadir}/aclocal
+ install -m 0644 ${S}/glib.m4 ${D}${datadir}/aclocal/glib-1.2.m4
+}
+
do_install_append () {
install -d ${D}${includedir}/glib-1.2
install -m 0644 glibconfig.h glib.h ${D}${includedir}/glib-1.2/
@@ -42,3 +53,7 @@ FILES_${PN}-dev += "${libdir}/glib/include/glibconfig.h"
SRC_URI[md5sum] = "6fe30dad87c77b91b632def29dd69ef9"
SRC_URI[sha256sum] = "6e1ce7eedae713b11db82f11434d455d8a1379f783a79812cd2e05fc024a8d9f"
+
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"