aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/glib-2.0/glib-2.0-2.16.1
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/glib-2.0/glib-2.0-2.16.1
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/glib-2.0/glib-2.0-2.16.1')
-rw-r--r--recipes/glib-2.0/glib-2.0-2.16.1/configure-libtool.patch29
-rw-r--r--recipes/glib-2.0/glib-2.0-2.16.1/gcc-4.2-inline-fix.patch29
-rw-r--r--recipes/glib-2.0/glib-2.0-2.16.1/hurd-arg-max.patch76
3 files changed, 134 insertions, 0 deletions
diff --git a/recipes/glib-2.0/glib-2.0-2.16.1/configure-libtool.patch b/recipes/glib-2.0/glib-2.0-2.16.1/configure-libtool.patch
new file mode 100644
index 0000000000..a52327c8c9
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.16.1/configure-libtool.patch
@@ -0,0 +1,29 @@
+--- glib-2.12.10/configure.in.orig 2006-06-05 13:34:08.000000000 +0100
++++ glib-2.12.10/configure.in 2006-06-05 13:34:36.000000000 +0100
+@@ -1174,7 +1174,7 @@
+ G_MODULE_LDFLAGS=
+ else
+ export SED
+- G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
++ G_MODULE_LDFLAGS=`(./$host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+ fi
+ dnl G_MODULE_IMPL= don't reset, so cmd-line can override
+ G_MODULE_NEED_USCORE=0
+@@ -1265,7 +1265,7 @@
+ LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
+ dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
+ echo "void glib_plugin_test(void) { }" > plugin.c
+- ${SHELL} ./libtool --mode=compile ${CC} -shared \
++ ${SHELL} ./$host_alias-libtool --mode=compile ${CC} -shared \
+ -export-dynamic -o plugin.o plugin.c 2>&1 >/dev/null
+ AC_CACHE_CHECK([for RTLD_GLOBAL brokenness],
+ glib_cv_rtldglobal_broken,[
+@@ -1339,7 +1339,7 @@
+
+ AC_MSG_CHECKING(for the suffix of shared libraries)
+ export SED
+-shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
++shrext_cmds=`./$host_alias-libtool --config | grep '^shrext_cmds='`
+ eval $shrext_cmds
+ module=yes eval std_shrext=$shrext_cmds
+ # chop the initial dot
diff --git a/recipes/glib-2.0/glib-2.0-2.16.1/gcc-4.2-inline-fix.patch b/recipes/glib-2.0/glib-2.0-2.16.1/gcc-4.2-inline-fix.patch
new file mode 100644
index 0000000000..b21851bd63
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.16.1/gcc-4.2-inline-fix.patch
@@ -0,0 +1,29 @@
+Stole from gentoo bugzilla
+http://bugs.gentoo.org/show_bug.cgi?id=156475
+
+Lets this work with gcc 4.2/4.3
+-Khem
+Index: glib-2.16.1/glib/gutils.h
+===================================================================
+--- glib-2.16.1.orig/glib/gutils.h 2008-03-10 17:31:56.000000000 -0700
++++ glib-2.16.1/glib/gutils.h 2008-06-04 15:19:12.000000000 -0700
+@@ -96,13 +96,14 @@
+ #ifdef G_IMPLEMENT_INLINES
+ # define G_INLINE_FUNC
+ # undef G_CAN_INLINE
+-#elif defined (__GNUC__)
+-# ifdef __GNUC_STDC_INLINE__
+-# define G_INLINE_FUNC extern inline __attribute__ ((__gnu_inline__))
++#elif defined (__GNUC__)
++# if __GNUC_PREREQ (4,2) && defined (__STDC_VERSION__) \
++ && __STDC_VERSION__ >= 199901L
++# define G_INLINE_FUNC extern __inline __attribute__ ((__gnu_inline__))
+ # else
+-# define G_INLINE_FUNC extern inline
++# define G_INLINE_FUNC extern __inline
+ # endif
+-#elif defined (G_CAN_INLINE)
++#elif defined (G_CAN_INLINE)
+ # define G_INLINE_FUNC static inline
+ #else /* can't inline */
+ # define G_INLINE_FUNC
diff --git a/recipes/glib-2.0/glib-2.0-2.16.1/hurd-arg-max.patch b/recipes/glib-2.0/glib-2.0-2.16.1/hurd-arg-max.patch
new file mode 100644
index 0000000000..36c9d15908
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.16.1/hurd-arg-max.patch
@@ -0,0 +1,76 @@
+Source: http://bugzilla.gnome.org/show_bug.cgi?id=522335
+
+This patch fixes the following error.
+
+| make[4]: Entering directory `/home/khem/oe/build/eglibc/tmp-qemuarm/work/armv5te-angstrom-linux-gnueabi/glib-2.0-2.16.1-r3/glib-2.16.1/glib'
+| if ccache arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=arm926ej-s -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DG_LOG_DOMAIN=\"GLib\" -DG_DISABLE_CAST_CHECKS -DG_DISABLE_ASSERT -DG_DISABLE_CHECKS -DG_DISABLE_DEPRECATED -DGLIB_COMPILATION -DPCRE_STATIC -isystem/home/khem/oe/build/eglibc/tmp-qemuarm/staging/arm-angstrom-linux-gnueabi/usr/include -pthread -isystem/home/khem/oe/build/eglibc/tmp-qemuarm/staging/arm-angstrom-linux-gnueabi/usr/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -Wall -MT gtester.o -MD -MP -MF ".deps/gtester.Tpo" -c -o gtester.o gtester.c; \
+| then mv -f ".deps/gtester.Tpo" ".deps/gtester.Po"; else rm -f ".deps/gtester.Tpo"; exit 1; fi
+| gtester.c: In function 'launch_test_binary':
+| gtester.c:276: error: 'ARG_MAX' undeclared (first use in this function)
+| gtester.c:276: error: (Each undeclared identifier is reported only once
+| gtester.c:276: error: for each function it appears in.)
+| gtester.c:276: warning: unused variable 'argv'
+| make[4]: *** [gtester.o] Error 1
+
+
+Index: glib-2.16.1/glib/gtester.c
+===================================================================
+--- glib-2.16.1.orig/glib/gtester.c (Revision 6750)
++++ glib-2.16.1/glib/gtester.c (Arbeitskopie)
+@@ -273,7 +273,8 @@
+ GTestLogBuffer *tlb;
+ GSList *slist, *free_list = NULL;
+ GError *error = NULL;
+- const gchar *argv[ARG_MAX];
++ int argc = 0;
++ const gchar **argv;
+ GPid pid = 0;
+ gint report_pipe[2] = { -1, -1 };
+ guint child_report_cb_id = 0;
+@@ -289,7 +290,34 @@
+ return FALSE;
+ }
+
++ /* setup argc */
++ for (slist = subtest_args; slist; slist = slist->next)
++ argc++;
++ /* argc++; */
++ if (subtest_quiet)
++ argc++;
++ if (subtest_verbose)
++ argc++;
++ if (!subtest_mode_fatal)
++ argc++;
++ if (subtest_mode_quick)
++ argc++;
++ else
++ argc++;
++ if (subtest_mode_perf)
++ argc++;
++ if (gtester_list_tests)
++ argc++;
++ if (subtest_seedstr)
++ argc++;
++ argc++;
++ if (skip_tests)
++ argc++;
++ for (slist = subtest_paths; slist; slist = slist->next)
++ argc++;
++
+ /* setup argv */
++ argv = g_malloc ((argc + 1) * sizeof(gchar *));
+ argv[i++] = binary;
+ for (slist = subtest_args; slist; slist = slist->next)
+ argv[i++] = (gchar*) slist->data;
+@@ -343,8 +371,10 @@
+ else
+ g_warning ("Failed to execute test binary: %s: %s", argv[0], error->message);
+ g_clear_error (&error);
++ g_free (argv);
+ return FALSE;
+ }
++ g_free (argv);
+
+ subtest_running = TRUE;
+ subtest_io_pending = TRUE;
+