summaryrefslogtreecommitdiffstats
path: root/recipes/glib-2.0/glib-2.0-2.22.1
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-12-09 09:40:56 -0800
committerKhem Raj <raj.khem@gmail.com>2009-12-09 09:40:56 -0800
commitff873fff3ac3fc92ac3e50d68eee8583ae60f478 (patch)
tree440a10ce79b36b423f368f13ec82798a1c292827 /recipes/glib-2.0/glib-2.0-2.22.1
parentb6fe201edfffdc585f9cf1780ad17ac19cf4cf95 (diff)
downloadopenembedded-ff873fff3ac3fc92ac3e50d68eee8583ae60f478.tar.gz
glib-2.0_2.22.1: Fix configure to test res_query by including resolv.h
* uclibc does not export res_query as weak like glibc, instead it exports __res_query and then in resolv.h it defines res_query as __res_query, the check for this fuction in configure checked the availability in every way except it did not check if the function is in C library by including resolv.h. Without resolv.h the function is reported as undefined. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/glib-2.0/glib-2.0-2.22.1')
-rw-r--r--recipes/glib-2.0/glib-2.0-2.22.1/uclibc-res_query.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/glib-2.0/glib-2.0-2.22.1/uclibc-res_query.patch b/recipes/glib-2.0/glib-2.0-2.22.1/uclibc-res_query.patch
new file mode 100644
index 0000000000..bbb34b5c09
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.22.1/uclibc-res_query.patch
@@ -0,0 +1,36 @@
+Index: glib-2.22.1/configure.in
+===================================================================
+--- glib-2.22.1.orig/configure.in 2009-12-08 12:01:39.000000000 -0800
++++ glib-2.22.1/configure.in 2009-12-08 12:05:29.000000000 -0800
+@@ -1004,17 +1004,22 @@ if test $glib_native_win32 = no; then
+ AC_CHECK_FUNC(res_query, ,
+ [AC_CHECK_LIB(resolv, res_query, [ LIBASYNCNS_LIBADD="-lresolv" ],
+ [ save_libs="$LIBS"
+- LIBS="-lresolv $LIBS"
+- AC_MSG_CHECKING([for res_query in -lresolv (alternate version)])
++ AC_MSG_CHECKING([for res_query (alternate version)])
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0,0,0,0)]])],
+- [ AC_MSG_RESULT(yes)
+- LIBASYNCNS_LIBADD="-lresolv" ],
+- [ AC_MSG_RESULT(no)
+- AC_CHECK_LIB(bind, res_query,
+- [ LIBASYNCNS_LIBADD="-lbind" ],
+- [ AC_MSG_ERROR(res_query not found) ] ) ] )
+- LIBS="$save_libs"
++ [ ac_cv_func_res_query=yes ],
++ [ AC_MSG_CHECKING([for res_query in -lresolv (alternate version)])
++ LIBS="-lresolv $LIBS"
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0,0,0,0)]])],
++ [ AC_MSG_RESULT(yes)
++ LIBASYNCNS_LIBADD="-lresolv" ],
++ [ AC_MSG_RESULT(no)
++ AC_CHECK_LIB(bind, res_query,
++ [ LIBASYNCNS_LIBADD="-lbind" ],
++ [ AC_MSG_ERROR(res_query not found) ] ) ] )
++ ] )
++ LIBS="$save_libs"
+ ] )
+ ]
+ )