aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/glib-2.0
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-10-13 17:07:25 -0700
committerKhem Raj <raj.khem@gmail.com>2009-10-13 17:11:16 -0700
commitaa038d682b4aec18c7408d228d544a74e2a3d894 (patch)
tree06b053fecc0a0e628a75b47be42d409469d90bc5 /recipes/glib-2.0
parent97dc77c75df5706bcd83a7f8afc77db194fe973f (diff)
downloadopenembedded-aa038d682b4aec18c7408d228d544a74e2a3d894.tar.gz
glib-2.0_2.22.1: Fix broken mc. Thanks zub for patch
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/glib-2.0')
-rw-r--r--recipes/glib-2.0/glib-2.0-2.22.1/g_once_init_enter.patch11
-rw-r--r--recipes/glib-2.0/glib-2.0_2.22.1.bb3
2 files changed, 13 insertions, 1 deletions
diff --git a/recipes/glib-2.0/glib-2.0-2.22.1/g_once_init_enter.patch b/recipes/glib-2.0/glib-2.0-2.22.1/g_once_init_enter.patch
new file mode 100644
index 0000000000..58e410884f
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.22.1/g_once_init_enter.patch
@@ -0,0 +1,11 @@
+--- glib-2.22.1/glib/gthread.h.orig 2009-10-13 22:53:23.000000000 +0200
++++ glib-2.22.1/glib/gthread.h 2009-10-13 23:34:59.000000000 +0200
+@@ -341,7 +341,7 @@
+ G_INLINE_FUNC gboolean
+ g_once_init_enter (volatile gsize *value_location)
+ {
+- if G_LIKELY ((gpointer) g_atomic_pointer_get (value_location) != NULL)
++ if G_LIKELY ((gpointer) g_atomic_pointer_get ((volatile gpointer *)value_location) != NULL)
+ return FALSE;
+ else
+ return g_once_init_enter_impl (value_location);
diff --git a/recipes/glib-2.0/glib-2.0_2.22.1.bb b/recipes/glib-2.0/glib-2.0_2.22.1.bb
index 5f915c2ee5..533116b825 100644
--- a/recipes/glib-2.0/glib-2.0_2.22.1.bb
+++ b/recipes/glib-2.0/glib-2.0_2.22.1.bb
@@ -1,11 +1,12 @@
require glib.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.22/glib-${PV}.tar.bz2 \
file://glibconfig-sysdefs.h \
file://configure-libtool.patch;patch=1 \
file://bug-556515.patch;patch=1 \
+ file://g_once_init_enter.patch;patch=1 \
"