summaryrefslogtreecommitdiffstats
path: root/recipes/glib-2.0
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-22 14:02:30 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-22 14:02:30 +0200
commit4914d6f9f448f5762d0f9596f325cc8e8b70d00a (patch)
tree8957f9739780100a9760079eba8341d061570fe0 /recipes/glib-2.0
parentac81f608727d7a72ac0f3713a5de61f463dc3752 (diff)
downloadopenembedded-4914d6f9f448f5762d0f9596f325cc8e8b70d00a.tar.gz
glib-2.0 2.24.0: apply two patches from release branch and one from ubuntu
Diffstat (limited to 'recipes/glib-2.0')
-rw-r--r--recipes/glib-2.0/glib-2.0-2.24.0/60_wait-longer-for-threads-to-die.patch26
-rw-r--r--recipes/glib-2.0/glib-2.0-2.24.0/gasync.patch22
-rw-r--r--[-rwxr-xr-x]recipes/glib-2.0/glib-2.0-2.24.0/gatomic_armv6.patch0
-rw-r--r--recipes/glib-2.0/glib-2.0-2.24.0/gvariant.patch32
-rw-r--r--recipes/glib-2.0/glib-2.0_2.24.0.bb5
5 files changed, 84 insertions, 1 deletions
diff --git a/recipes/glib-2.0/glib-2.0-2.24.0/60_wait-longer-for-threads-to-die.patch b/recipes/glib-2.0/glib-2.0-2.24.0/60_wait-longer-for-threads-to-die.patch
new file mode 100644
index 0000000000..02fe9ff0ab
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.24.0/60_wait-longer-for-threads-to-die.patch
@@ -0,0 +1,26 @@
+--- glib/tests/threadpool-test.c.old 2008-02-12 06:11:21.000000000 +0100
++++ glib/tests/threadpool-test.c 2008-02-12 06:11:52.000000000 +0100
+@@ -5,8 +5,8 @@
+
+ #include <glib.h>
+
+-#define DEBUG_MSG(x)
+-/* #define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n"); */
++/* #define DEBUG_MSG(x) */
++#define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n");
+
+ #define WAIT 5 /* seconds */
+ #define MAX_THREADS 10
+@@ -124,10 +124,10 @@
+ DEBUG_MSG (("[unused] stopping unused threads"));
+ g_thread_pool_stop_unused_threads ();
+
+- DEBUG_MSG (("[unused] waiting ONE second for threads to die"));
++ DEBUG_MSG (("[unused] waiting FIVE second for threads to die"));
+
+ /* Some time for threads to die. */
+- g_usleep (G_USEC_PER_SEC);
++ g_usleep (5 * G_USEC_PER_SEC);
+
+ DEBUG_MSG (("[unused] stopped idle threads, %d remain, %d threads still exist",
+ g_thread_pool_get_num_unused_threads (),
diff --git a/recipes/glib-2.0/glib-2.0-2.24.0/gasync.patch b/recipes/glib-2.0/glib-2.0-2.24.0/gasync.patch
new file mode 100644
index 0000000000..d9f36a757e
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.24.0/gasync.patch
@@ -0,0 +1,22 @@
+From 324f928af62d8a0aa132a5caaec107d4daa76429 Mon Sep 17 00:00:00 2001
+From: David Zeuthen <davidz@redhat.com>
+Date: Mon, 19 Apr 2010 14:42:42 +0000
+Subject: Bug 615111 – GAsyncInitable's default implementation is broken
+
+Signed-off-by: David Zeuthen <davidz@redhat.com>
+---
+diff --git a/gio/gasyncinitable.c b/gio/gasyncinitable.c
+index 05e17e2..c369a4e 100644
+--- a/gio/gasyncinitable.c
++++ b/gio/gasyncinitable.c
+@@ -201,7 +201,7 @@ async_init_thread (GSimpleAsyncResult *res,
+ {
+ GError *error = NULL;
+
+- if (!g_initable_init (G_INITABLE (res), cancellable, &error))
++ if (!g_initable_init (G_INITABLE (object), cancellable, &error))
+ {
+ g_simple_async_result_set_from_error (res, error);
+ g_error_free (error);
+--
+cgit v0.8.3.1
diff --git a/recipes/glib-2.0/glib-2.0-2.24.0/gatomic_armv6.patch b/recipes/glib-2.0/glib-2.0-2.24.0/gatomic_armv6.patch
index b17f80dbab..b17f80dbab 100755..100644
--- a/recipes/glib-2.0/glib-2.0-2.24.0/gatomic_armv6.patch
+++ b/recipes/glib-2.0/glib-2.0-2.24.0/gatomic_armv6.patch
diff --git a/recipes/glib-2.0/glib-2.0-2.24.0/gvariant.patch b/recipes/glib-2.0/glib-2.0-2.24.0/gvariant.patch
new file mode 100644
index 0000000000..633f0aa8f3
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.24.0/gvariant.patch
@@ -0,0 +1,32 @@
+From e51ec13ab4bc629f73b41f2ad3e96b3a787a8760 Mon Sep 17 00:00:00 2001
+From: Ryan Lortie <desrt@desrt.ca>
+Date: Sun, 11 Apr 2010 02:01:02 +0000
+Subject: Add g_return_if_fail()s to g_variant_new_from_data()
+
+also, document that @type must be definite
+---
+diff --git a/glib/gvariant.c b/glib/gvariant.c
+index 721740f..f8f29e0 100644
+--- a/glib/gvariant.c
++++ b/glib/gvariant.c
+@@ -4087,7 +4087,7 @@ g_variant_byteswap (GVariant *value)
+
+ /**
+ * g_variant_new_from_data:
+- * @type: a #GVariantType
++ * @type: a definite #GVariantType
+ * @data: the serialised data
+ * @size: the size of @data
+ * @trusted: %TRUE if @data is definitely in normal form
+@@ -4129,6 +4129,9 @@ g_variant_new_from_data (const GVariantType *type,
+ GVariant *value;
+ GBuffer *buffer;
+
++ g_return_val_if_fail (g_variant_type_is_definite (type), NULL);
++ g_return_val_if_fail (data != NULL || size == 0, NULL);
++
+ if (notify)
+ buffer = g_buffer_new_from_pointer (data, size, notify, user_data);
+ else
+--
+cgit v0.8.3.1
diff --git a/recipes/glib-2.0/glib-2.0_2.24.0.bb b/recipes/glib-2.0/glib-2.0_2.24.0.bb
index 0f2123b840..ad94111863 100644
--- a/recipes/glib-2.0/glib-2.0_2.24.0.bb
+++ b/recipes/glib-2.0/glib-2.0_2.24.0.bb
@@ -8,7 +8,7 @@ SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl zlib"
-PR = "r3"
+PR = "r4"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.24/glib-${PV}.tar.bz2;name=archive \
@@ -17,6 +17,9 @@ SRC_URI = "\
file://g_once_init_enter.patch;patch=1 \
file://gatomic-proper-pointer-get-cast.patch;patch=1 \
file://gio.patch;patch=1 \
+ file://gvariant.patch;patch=1 \
+ file://gasync.patch;patch=1 \
+ file://60_wait-longer-for-threads-to-die.patch;patch=1 \
"
SRC_URI[archive.md5sum] = "45a8bc697d07f859566c0b64c40382a8"