summaryrefslogtreecommitdiffstats
path: root/recipes/glib-2.0
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-29 13:03:54 +0400
committerRoman I Khimov <khimov@altell.ru>2010-03-29 13:57:41 +0400
commitb064810bbb62b6dab5a88cba539258eff9a4e603 (patch)
treecb5783fa2e5a6d7f6d186beb5a727c0216a3775c /recipes/glib-2.0
parentda8cf4d9f68bfd02e95bf391082cc33ca84f277d (diff)
downloadopenembedded-b064810bbb62b6dab5a88cba539258eff9a4e603.tar.gz
glib-2.0_2.23.6: add gatomic-proper-pointer-get-cast.patch
Fixes "cast discards qualifiers from pointer target type" warning on gthread.h:348 which is especially annoying when package is being built with -Werror. 2.22 glib branch is not affected. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/glib-2.0')
-rw-r--r--recipes/glib-2.0/glib-2.0-2.23.6/gatomic-proper-pointer-get-cast.patch13
-rw-r--r--recipes/glib-2.0/glib-2.0_2.23.6.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/glib-2.0/glib-2.0-2.23.6/gatomic-proper-pointer-get-cast.patch b/recipes/glib-2.0/glib-2.0-2.23.6/gatomic-proper-pointer-get-cast.patch
new file mode 100644
index 0000000000..5e8f836cb2
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.23.6/gatomic-proper-pointer-get-cast.patch
@@ -0,0 +1,13 @@
+Index: glib-2.23.6/glib/gatomic.h
+===================================================================
+--- glib-2.23.6.orig/glib/gatomic.h 2010-03-29 13:01:28.000000000 +0400
++++ glib-2.23.6/glib/gatomic.h 2010-03-29 13:01:35.000000000 +0400
+@@ -70,7 +70,7 @@
+ (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (void *) (atomic), (newval)))
+ # define g_atomic_pointer_get(atomic) \
+ ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
+- (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (void *) (atomic)))
++ (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void G_GNUC_MAY_ALIAS *) (atomic)))
+ # define g_atomic_pointer_set(atomic, newval) \
+ ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
+ (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (void *) (atomic), (newval)))
diff --git a/recipes/glib-2.0/glib-2.0_2.23.6.bb b/recipes/glib-2.0/glib-2.0_2.23.6.bb
index 68d401ad1a..dfbda5cd30 100644
--- a/recipes/glib-2.0/glib-2.0_2.23.6.bb
+++ b/recipes/glib-2.0/glib-2.0_2.23.6.bb
@@ -7,13 +7,14 @@ LICENSE = "LGPL"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl zlib"
-PR = "r1"
+PR = "r2"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.23/glib-${PV}.tar.bz2;name=archive \
file://glibconfig-sysdefs.h \
file://configure-libtool.patch;patch=1 \
file://g_once_init_enter.patch;patch=1 \
+ file://gatomic-proper-pointer-get-cast.patch;patch=1 \
"
SRC_URI[archive.md5sum] = "72e6eadc16d7022376ecef12c6fe905e"
SRC_URI[archive.sha256sum] = "f91840e27ad4cd48e655a6babed7e2024f86814f94961da88ca2adba447c6e77"