summaryrefslogtreecommitdiffstats
path: root/recipes/glibc
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2009-10-22 03:47:41 +0000
committerKhem Raj <raj.khem@gmail.com>2009-10-22 16:50:16 -0700
commitff9665cf99b28e59ab8622d1a68f77b41a53a5a7 (patch)
treeb9d5e27b876de036f6e01d5c5868ba2e2bbd6c5f /recipes/glibc
parent077f07332ce734c13cf53a59b69c4664e50458ba (diff)
downloadopenembedded-ff9665cf99b28e59ab8622d1a68f77b41a53a5a7.tar.gz
binutils-2.20 is new enough for glibc_2.9, change configure script to accept it
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/glibc')
-rw-r--r--recipes/glibc/glibc-2.9/glibc-2.9-enable-binutils-2.2.patch35
-rw-r--r--recipes/glibc/glibc_2.9.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/glibc/glibc-2.9/glibc-2.9-enable-binutils-2.2.patch b/recipes/glibc/glibc-2.9/glibc-2.9-enable-binutils-2.2.patch
new file mode 100644
index 0000000000..09200dd43b
--- /dev/null
+++ b/recipes/glibc/glibc-2.9/glibc-2.9-enable-binutils-2.2.patch
@@ -0,0 +1,35 @@
+--- glibc-2.9.orig/configure.in 2009-10-22 15:38:13.000000000 +0200
++++ glibc-2.9/configure.in 2009-10-22 15:37:33.000000000 +0200
+@@ -844,10 +844,10 @@
+ # Accept binutils 2.13 or newer.
+ AC_CHECK_PROG_VER(AS, $AS, --version,
+ [GNU assembler.* \([0-9]*\.[0-9.]*\)],
+- [2.1[3-9]*], AS=: critic_missing="$critic_missing as")
++ [2.1[3-9]* | 2.2* ], AS=: critic_missing="$critic_missing as")
+ AC_CHECK_PROG_VER(LD, $LD, --version,
+ [GNU ld.* \([0-9][0-9]*\.[0-9.]*\)],
+- [2.1[3-9]*], LD=: critic_missing="$critic_missing ld")
++ [2.1[3-9]* | 2.2* ], LD=: critic_missing="$critic_missing ld")
+
+ # We need the physical current working directory. We cannot use the
+ # "pwd -P" shell builtin since that's not portable. Instead we try to
+--- glibc-2.9.orig/configure 2009-02-26 22:28:17.000000000 +0100
++++ glibc-2.9/configure 2009-10-22 15:43:11.000000000 +0200
+@@ -4531,7 +4531,7 @@
+ ac_prog_version=`$AS --version 2>&1 | sed -n 's/^.*GNU assembler.* \([0-9]*\.[0-9.]*\).*$/\1/p'`
+ case $ac_prog_version in
+ '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+- 2.1[3-9]*)
++ 2.1[3-9]* | 2.2*)
+ ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+ *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+
+@@ -4594,7 +4594,7 @@
+ ac_prog_version=`$LD --version 2>&1 | sed -n 's/^.*GNU ld.* \([0-9][0-9]*\.[0-9.]*\).*$/\1/p'`
+ case $ac_prog_version in
+ '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+- 2.1[3-9]*)
++ 2.1[3-9]* | 2.2*)
+ ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+ *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+
diff --git a/recipes/glibc/glibc_2.9.bb b/recipes/glibc/glibc_2.9.bb
index 56a6ff8d47..cddae98b08 100644
--- a/recipes/glibc/glibc_2.9.bb
+++ b/recipes/glibc/glibc_2.9.bb
@@ -65,6 +65,7 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
file://tls_i486.patch;patch=1 \
file://glibc-2.9-use-_begin.patch;patch=1 \
file://arm-lowlevellock-include-tls.patch;patch=1 \
+ file://glibc-2.9-enable-binutils-2.2.patch;patch=1 \
"
# Build fails on sh3 and sh4 without additional patches