aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/glibmm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/glibmm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/glibmm')
-rw-r--r--recipes/glibmm/glibmm.inc24
-rw-r--r--recipes/glibmm/glibmm_2.16.2.bb1
-rw-r--r--recipes/glibmm/glibmm_2.18.0.bb1
3 files changed, 26 insertions, 0 deletions
diff --git a/recipes/glibmm/glibmm.inc b/recipes/glibmm/glibmm.inc
new file mode 100644
index 0000000000..c33d3151ae
--- /dev/null
+++ b/recipes/glibmm/glibmm.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "C++ bindings for the glib library."
+HOMEPAGE = "http://www.gtkmm.org/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "glib-2.0 libsigc++-2.0"
+PR = "r0"
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV}.tar.bz2"
+
+inherit autotools pkgconfig flow-lossage
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/glibmm-2.4/include/"
+
+LIBV = "2.4.0"
+
+do_stage () {
+ autotools_stage_all
+
+ install -m 0644 glib/glibmmconfig.h ${STAGING_INCDIR}/glibmm-2.4
+ install -m 0644 scripts/glibmm_check_perl.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/recipes/glibmm/glibmm_2.16.2.bb b/recipes/glibmm/glibmm_2.16.2.bb
new file mode 100644
index 0000000000..90a053fb36
--- /dev/null
+++ b/recipes/glibmm/glibmm_2.16.2.bb
@@ -0,0 +1 @@
+require glibmm.inc
diff --git a/recipes/glibmm/glibmm_2.18.0.bb b/recipes/glibmm/glibmm_2.18.0.bb
new file mode 100644
index 0000000000..90a053fb36
--- /dev/null
+++ b/recipes/glibmm/glibmm_2.18.0.bb
@@ -0,0 +1 @@
+require glibmm.inc