aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnash/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gnash/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gnash/files')
-rw-r--r--recipes/gnash/files/fix-trunc.diff13
-rw-r--r--recipes/gnash/files/libintl.patch13
-rw-r--r--recipes/gnash/files/libtool-2.2.patch35
3 files changed, 61 insertions, 0 deletions
diff --git a/recipes/gnash/files/fix-trunc.diff b/recipes/gnash/files/fix-trunc.diff
new file mode 100644
index 0000000000..a01ca311d0
--- /dev/null
+++ b/recipes/gnash/files/fix-trunc.diff
@@ -0,0 +1,13 @@
+--- /tmp/utility.h 2008-09-02 16:35:44.000000000 +0200
++++ gnash/libbase/utility.h 2008-09-02 16:36:10.000000000 +0200
+@@ -327,6 +327,10 @@
+ #endif
+ }
+
++#ifndef HAVE_TRUNC
++inline double trunc(double x) { return (x < 0 ? -(std::floor(-x)) : std::floor(x)); }
++#endif
++
+ #endif // UTILITY_H
+
+
diff --git a/recipes/gnash/files/libintl.patch b/recipes/gnash/files/libintl.patch
new file mode 100644
index 0000000000..22e1acb65b
--- /dev/null
+++ b/recipes/gnash/files/libintl.patch
@@ -0,0 +1,13 @@
+Index: gnash-0.8.3/gui/am-frag/fb.am
+===================================================================
+--- gnash-0.8.3.orig/gui/am-frag/fb.am 2008-08-19 00:37:45.000000000 +0200
++++ gnash-0.8.3/gui/am-frag/fb.am 2008-08-19 00:38:04.000000000 +0200
+@@ -30,7 +30,7 @@
+ fb_gnash_CPPFLAGS += $(AGG_CFLAGS)
+ fb_gnash_SOURCES +=
+ fb_gnash_LDADD = $(top_builddir)/backend/libgnashagg.la \
+- $(GNASH_LIBS) $(AGG_LIBS)
++ $(GNASH_LIBS) $(AGG_LIBS) $(INTLLIBS)
+ endif # BUILD_AGG_RENDERER
+ endif # BUILD_FB_GUI
+
diff --git a/recipes/gnash/files/libtool-2.2.patch b/recipes/gnash/files/libtool-2.2.patch
new file mode 100644
index 0000000000..f0ec274104
--- /dev/null
+++ b/recipes/gnash/files/libtool-2.2.patch
@@ -0,0 +1,35 @@
+diff -NrU5 gnash-0.8.3.orig/libbase/Makefile.am gnash-0.8.3/libbase/Makefile.am
+--- gnash-0.8.3.orig/libbase/Makefile.am 2008-06-26 22:56:12.000000000 +0200
++++ gnash-0.8.3/libbase/Makefile.am 2008-06-26 22:57:48.000000000 +0200
+@@ -19,13 +19,13 @@
+
+ # this is where Gnash plugins get installed
+ pluginsdir = $(prefix)/lib/gnash/plugins
+
+ if INSTALL_LTDL
+-include_HEADERS = $(top_srcdir)/libltdl/ltdl.h
+-LIBLTDLLIB = libltdl.la
+-LIBLTDLHEAD = $(top_srcdir)/libltdl/ltdl.h
++#include_HEADERS = $(top_srcdir)/libltdl/ltdl.h
++#LIBLTDLLIB = libltdl.la
++#LIBLTDLHEAD = $(top_srcdir)/libltdl/ltdl.h
+ endif
+
+ sysconf_DATA = gnashrc gnashpluginrc
+
+ edit = sed \
+@@ -174,12 +174,12 @@
+
+ libgnashbase_la_LDFLAGS = -release $(VERSION)
+
+ libltdlc_la_CPPFLAGS = $(LTDLINCL)
+ if CONVENIENCE_LTDL
+-noinst_LTLIBRARIES = libltdlc.la
+-libltdlc_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
++#noinst_LTLIBRARIES = libltdlc.la
++#libltdlc_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
+ endif
+ CLEANFILES = libltdl.la libltdlc.la gnashrc gnashpluginrc
+
+ libltdl_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
+ libltdl_la_LDFLAGS = -no-undefined -version-info 4:4:1