summaryrefslogtreecommitdiffstats
path: root/recipes/gnash/gnash_0.8.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gnash/gnash_0.8.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gnash/gnash_0.8.4.bb')
-rw-r--r--recipes/gnash/gnash_0.8.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/gnash/gnash_0.8.4.bb b/recipes/gnash/gnash_0.8.4.bb
new file mode 100644
index 0000000000..0a9c780cc4
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.4.bb
@@ -0,0 +1,24 @@
+require gnash.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+do_configure_prepend() {
+ sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:LIBPNG:PNG:g $i
+ done
+ export CFLAGS="${CFLAGS} -lpng"
+}
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --enable-png \
+ --with-png-incl=${STAGING_INCDIR} \
+ --with-png-lib=${STAGING_LIBDIR} \
+ "
+