aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnet
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gnet
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gnet')
-rw-r--r--recipes/gnet/files/buildfix.patch13
-rw-r--r--recipes/gnet/gnet_cvs.bb18
-rw-r--r--recipes/gnet/gnet_svn.bb21
3 files changed, 52 insertions, 0 deletions
diff --git a/recipes/gnet/files/buildfix.patch b/recipes/gnet/files/buildfix.patch
new file mode 100644
index 0000000000..8067620264
--- /dev/null
+++ b/recipes/gnet/files/buildfix.patch
@@ -0,0 +1,13 @@
+Index: gnet/examples/Makefile.am
+===================================================================
+--- gnet.orig/examples/Makefile.am
++++ gnet/examples/Makefile.am
+@@ -2,7 +2,7 @@
+
+ @SET_MAKE@
+
+-SUBDIRS = xmlrpc
++SUBDIRS =
+
+ if OS_WIN32
+ noinst_PROGRAMS = echoclient echoserver \
diff --git a/recipes/gnet/gnet_cvs.bb b/recipes/gnet/gnet_cvs.bb
new file mode 100644
index 0000000000..b36df17c18
--- /dev/null
+++ b/recipes/gnet/gnet_cvs.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "GNet is a simple network library. It is written in C, object-oriented, and built upon GLib."
+LICENSE = "LGPL"
+SECTION = "libs/network"
+HOMEPAGE = "http://www.gnetlibrary.org"
+DEPENDS = "glib-2.0"
+PV = "2.0.7+cvs${SRCDATE}"
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gnet \
+ file://buildfix.patch;patch=1"
+S = "${WORKDIR}/gnet"
+
+EXTRA_OECONF = "--disable-pthreads"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/gnet/gnet_svn.bb b/recipes/gnet/gnet_svn.bb
new file mode 100644
index 0000000000..c09b7f8b9c
--- /dev/null
+++ b/recipes/gnet/gnet_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GNet is a simple network library. It is written in C, object-oriented, and built upon GLib."
+LICENSE = "LGPL"
+SECTION = "libs/network"
+HOMEPAGE = "http://www.gnetlibrary.org"
+DEPENDS = "glib-2.0"
+PV = "2.0.7+svn${SRCDATE}"
+
+SRC_URI = "svn://svn.gnome.org/svn/${PN}/;module=trunk \
+ file://buildfix.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--disable-pthreads"
+
+FILES_${PN}-dev += "${libdir}/gnet-2.0"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}