aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/at-spi_1.28.0.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-01-21 00:09:17 +0000
committerGraeme Gregory <dp@xora.org.uk>2010-01-21 00:09:17 +0000
commit2154e8eb1a513d0944da59a780f962bacd0bcb8f (patch)
tree9311cd11f371f31cbf4b3a3ea35c63722102ab78 /recipes/gnome/at-spi_1.28.0.bb
parentd99a0541bf481893373198f74ce67a6017c5f978 (diff)
downloadopenembedded-2154e8eb1a513d0944da59a780f962bacd0bcb8f.tar.gz
at-spi_1.28.0.bb : fix compile on systems without host installen gnome devel
The configure script was generation paths in /usr/* when looking for orbit-2-idl and bonobo idl files so feed our staging paths in instead.
Diffstat (limited to 'recipes/gnome/at-spi_1.28.0.bb')
-rw-r--r--recipes/gnome/at-spi_1.28.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes/gnome/at-spi_1.28.0.bb b/recipes/gnome/at-spi_1.28.0.bb
index 3639407eb6..79b48b3f1b 100644
--- a/recipes/gnome/at-spi_1.28.0.bb
+++ b/recipes/gnome/at-spi_1.28.0.bb
@@ -6,8 +6,16 @@ LICENSE = "LGPL"
DEPENDS = "gtk+ atk libbonobo orbit2 orbit2-native"
RDEPENDS_${PN} = "libgail-gnome gtk-module-gail"
+PR = "r1"
+
inherit gnome
+do_configure_prepend () {
+ sed -i "s|ORBIT_IDL=.*|ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2|" ${S}/configure.in
+ sed -i "s|BONOBO_ACTIVATION_IDL_DIR=.*|BONOBO_ACTIVATION_IDL_DIR=${STAGING_DATADIR}/idl/bonobo-activation-2.0|" ${S}/configure.in
+ sed -i "s|LIBBONOBO_IDL_DIR=.*|LIBBONOBO_IDL_DIR=${STAGING_DATADIR}/idl//bonobo-2.0|" ${S}/configure.in
+}
+
do_stage () {
autotools_stage_all
}