aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gconf_2.6.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gnome/gconf_2.6.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gnome/gconf_2.6.1.bb')
-rw-r--r--recipes/gnome/gconf_2.6.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/gnome/gconf_2.6.1.bb b/recipes/gnome/gconf_2.6.1.bb
new file mode 100644
index 0000000000..9b9db4abb4
--- /dev/null
+++ b/recipes/gnome/gconf_2.6.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "GNOME configuration database system"
+SECTION = "x11/gnome"
+LICENSE = "LGPL"
+DEPENDS = "orbit2 glib-2.0 libxml2"
+ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+PR = "r2"
+
+S = "${WORKDIR}/GConf-${PV}"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.6/GConf-${PV}.tar.bz2 \
+ file://backends.patch;patch=1"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+
+inherit autotools pkgconfig gettext
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gconf/2/gconf/
+ ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
+ install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}
+
+FILES_${PN} += " ${libdir}/GConf/*"
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"