aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gedit_2.26.2.bb
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-06 09:42:03 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-08 11:20:06 +0200
commitaa5fa3a8bd5044e132284910e4cf864702b0c01f (patch)
tree52c3acf09bc871abda343611d0ca4ee97c487c18 /recipes/gnome/gedit_2.26.2.bb
parent853caf13db02d98a9d19f016b2f105bb96d3954b (diff)
downloadopenembedded-aa5fa3a8bd5044e132284910e4cf864702b0c01f.tar.gz
gedit: add 2.6.22
Diffstat (limited to 'recipes/gnome/gedit_2.26.2.bb')
-rw-r--r--recipes/gnome/gedit_2.26.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gnome/gedit_2.26.2.bb b/recipes/gnome/gedit_2.26.2.bb
new file mode 100644
index 0000000000..a0585f10e6
--- /dev/null
+++ b/recipes/gnome/gedit_2.26.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GNOME editor"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+
+DEPENDS = "gnome-common glib-2.0 gtk+ gconf gtksourceview2"
+RDEPENDS += " gtksourceview2"
+
+inherit gnome pkgconfig
+
+EXTRA_OECONF = "--disable-scrollkeeper"
+
+do_configure_prepend () {
+ cp ${STAGING_DATADIR}/gnome-common/data/omf.make ${S}
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir} ${datadir}/gedit-2"
+FILES_${PN}-dbg += "${libdir}/gedit-2/plugin-loaders/.debug ${libdir}/gedit-2/plugins/.debug"