aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-games_2.6.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gnome/gnome-games_2.6.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gnome/gnome-games_2.6.1.bb')
-rw-r--r--recipes/gnome/gnome-games_2.6.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-games_2.6.1.bb b/recipes/gnome/gnome-games_2.6.1.bb
new file mode 100644
index 0000000000..d1ac41b08a
--- /dev/null
+++ b/recipes/gnome/gnome-games_2.6.1.bb
@@ -0,0 +1,25 @@
+LICENSE = "GPL"
+DEPENDS = "guile gtk+ libgnome libgnomeui librsvg gnome-vfs gconf libglade gnome-common"
+PR = "r2"
+
+inherit gnome
+
+PACKAGES =+ "libgdkcardimage libgdkcardimage-data libgdkcardimage-dev"
+
+FILES_libgdkcardimage = "${libdir}/libgdkcardimage.so.*"
+FILES_libgdkcardimage-dev = "${libdir}/libgdkcardimage.* ${includedir}/gdkcardimage"
+FILES_libgdkcardimage-data = "${datadir}/pixmaps/cards"
+DEPENDS_libgdkcardimage = "libgdkcardimage-data"
+
+FILES_${PN}-doc += " ${datadir}/gnome/help"
+
+PACKAGES =+ "gnome-games-sol "
+FILES_gnome-games-sol = "${bindir}/sol ${datadir}/applications/sol.desktop ${datadir}/pixmaps/gnome-aisleriot.png ${sysconfdir}/gconf/schemas/aisleriot.schemas ${datadir}/sol-games"
+
+PACKAGES =+ "gnome-games-gnometris "
+FILES_gnome-games-gnometris = "${bindir}/gnometris ${datadir}/pixmaps/gnometris ${datadir}/pixmaps/gnome-gtetris.png ${datadir}/applications/gnometris.desktop ${sysconfdir}/gconf/schemas/gnometris.schemas"
+
+PACKAGES =+ "gnome-games-gnomine"
+FILES_gnome-games-gnomine = "${bindir}/gnomine ${datadir}/pixmaps/gnomine ${datadir}/pixmaps/gnome-gnomine.png ${datadir}/applications/gnomine.desktop ${sysconfdir}/gconf/schemas/gnomine.schemas"
+
+EXTRA_OECONF = "--disable-schemas-install"