aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-panel_2.26.0.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-04-09 15:06:10 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-04-09 15:06:10 +0000
commita3cce179d238dc0a503ab80086796d4442a4dce2 (patch)
treed815f116e56208f9f23d78149817ebb54000b3b9 /recipes/gnome/gnome-panel_2.26.0.bb
parent71e5e4f51401bae4c63c712a9c15faad8270e4a1 (diff)
downloadopenembedded-a3cce179d238dc0a503ab80086796d4442a4dce2.tar.gz
gnome-panel: Compile idl files against STAGING_DIR_HOST.
Diffstat (limited to 'recipes/gnome/gnome-panel_2.26.0.bb')
-rw-r--r--recipes/gnome/gnome-panel_2.26.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/gnome/gnome-panel_2.26.0.bb b/recipes/gnome/gnome-panel_2.26.0.bb
index b2d615a750..608dd883c7 100644
--- a/recipes/gnome/gnome-panel_2.26.0.bb
+++ b/recipes/gnome/gnome-panel_2.26.0.bb
@@ -3,6 +3,8 @@ DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome
inherit gnome pkgconfig
+SRC_URI += "file://idl-sysroot.patch;patch=1"
+
do_configure_prepend() {
sed -i -e s:help:: ${S}/Makefile.am
}
@@ -14,7 +16,8 @@ FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
FILES_${PN} =+ "${datadir}/gnome* \
${datadir}/icons"
-EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+export SYSROOT = "${STAGING_DIR_HOST}"
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2 SYSROOT=${SYSROOT}"
EXTRA_OECONF = "--disable-scrollkeeper \
--disable-eds \
"