aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-python-extras_2.25.3.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-21 14:16:28 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-21 15:27:33 +0200
commit9fb7e7b2d2f2563a78e128da8377bff110ad7775 (patch)
tree5ca028bb0310513c3ebd32a93755862b63a8a88e /recipes/gnome/gnome-python-extras_2.25.3.bb
parent57e9e4b5b25f328cd24d53789992d1c967cb7daa (diff)
downloadopenembedded-9fb7e7b2d2f2563a78e128da8377bff110ad7775.tar.gz
gnome-python-extras: fix up patch to python stuff
Diffstat (limited to 'recipes/gnome/gnome-python-extras_2.25.3.bb')
-rw-r--r--recipes/gnome/gnome-python-extras_2.25.3.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/gnome/gnome-python-extras_2.25.3.bb b/recipes/gnome/gnome-python-extras_2.25.3.bb
index 9d8e786241..cf3d84e9af 100644
--- a/recipes/gnome/gnome-python-extras_2.25.3.bb
+++ b/recipes/gnome/gnome-python-extras_2.25.3.bb
@@ -5,12 +5,17 @@ inherit gnome distutils-base
SRC_URI += "file://acinclude.m4"
+EXTRA_OECONF = "--with-python-includes=${STAGING_INCDIR}/../"
+
do_configure_prepend() {
install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
}
do_configure_prepend() {
- sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes/\":g \
+ ${S}/configure.ac
}
AUTOTOOLS_STAGE_PKGCONFIG = "1"