aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-python_2.26.1.bb
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-08 15:12:29 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-09 16:16:39 +0200
commit2215a06d3408f57cf4edd5a072132333111c3830 (patch)
tree473be452e5a0aa208d996ab033637b610b009f62 /recipes/gnome/gnome-python_2.26.1.bb
parent48d4343132b55bb3ae2bd06e602660fc0f584b2f (diff)
downloadopenembedded-2215a06d3408f57cf4edd5a072132333111c3830.tar.gz
gnome-python: add 2.26.1
Diffstat (limited to 'recipes/gnome/gnome-python_2.26.1.bb')
-rw-r--r--recipes/gnome/gnome-python_2.26.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-python_2.26.1.bb b/recipes/gnome/gnome-python_2.26.1.bb
new file mode 100644
index 0000000000..1027437b7a
--- /dev/null
+++ b/recipes/gnome/gnome-python_2.26.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GNOME Python miscellaneous bindings"
+LICENSE = "LGPL"
+DEPENDS = "libgnomeui pyorbit python-pygtk"
+RDEPENDS = "pyorbit"
+
+inherit gnome distutils-base pkgconfig
+
+do_configure() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ autotools_do_configure
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}"
+FILES_${PN}-dbg += "${libdir}/gnome-vfs-2.0/modules/.debug"
+
+