summaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-settings-daemon_2.28.0.bb
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-10-01 21:12:57 -0700
committerKoen Kooi <koen@openembedded.org>2009-10-02 10:08:28 +0200
commit37e4d79aede899aba0629a765ea0fd2e46ee4f72 (patch)
tree7b27c654d4fa9d71e2531ff9073c6d5c55c2806f /recipes/gnome/gnome-settings-daemon_2.28.0.bb
parent4e9f41a8c6c8f20237e0ccc200c550e45388bdec (diff)
downloadopenembedded-37e4d79aede899aba0629a765ea0fd2e46ee4f72.tar.gz
gnome-settings-daemon: add 2.28.0
Diffstat (limited to 'recipes/gnome/gnome-settings-daemon_2.28.0.bb')
-rw-r--r--recipes/gnome/gnome-settings-daemon_2.28.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-settings-daemon_2.28.0.bb b/recipes/gnome/gnome-settings-daemon_2.28.0.bb
new file mode 100644
index 0000000000..23f47771d8
--- /dev/null
+++ b/recipes/gnome/gnome-settings-daemon_2.28.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "GNOME settings daemon"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+
+DEPENDS = "libxklavier libgnomekbd libgnomeui gnome-desktop gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl"
+
+inherit gnome
+
+CFLAGS += "-lgthread-2.0"
+
+FILES_${PN} += "${libdir}/gnome-settings-daemon-2.0/*.so \
+ ${libdir}/gnome-settings-daemon-2.0/*plugin \
+ ${datadir}/dbus-1/ \
+ ${datadir}/gnome-control-center \
+ ${datadir}/icons \
+ "
+
+FILES_${PN}-dbg += "${libdir}/gnome-settings-daemon-2.0/.debug"
+FILES_${PN}-dev += "${libdir}/gnome-settings-daemon-2.0/*.a ${libdir}/gnome-settings-daemon-2.0/*.la"
+
+do_configure_prepend () {
+ sed -i 's:$CPPFLAGS -I$includedir:$CPPFLAGS:' ${S}/configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+