aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/goffice_0.7.14.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-29 11:21:56 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-29 11:21:56 +0100
commit1314ecdc7f2db73e7eb0a3910ed87406f2128a62 (patch)
treef70ea953dfc1fd3baefbfea08ccdd19f80c17fb6 /recipes/gnome/goffice_0.7.14.bb
parent31c440b89cf2f9002bc8df2f69a34b4948f0d0de (diff)
downloadopenembedded-1314ecdc7f2db73e7eb0a3910ed87406f2128a62.tar.gz
goffice: fix packaging
Diffstat (limited to 'recipes/gnome/goffice_0.7.14.bb')
-rw-r--r--recipes/gnome/goffice_0.7.14.bb29
1 files changed, 26 insertions, 3 deletions
diff --git a/recipes/gnome/goffice_0.7.14.bb b/recipes/gnome/goffice_0.7.14.bb
index 9fff0b4cfe..77dd39ad79 100644
--- a/recipes/gnome/goffice_0.7.14.bb
+++ b/recipes/gnome/goffice_0.7.14.bb
@@ -1,9 +1,9 @@
DESCRIPTION="Gnome Office Library"
LICENSE="GPLv2"
-DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
+PR = "r1"
-FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
inherit gnome pkgconfig
@@ -11,10 +11,33 @@ do_stage() {
autotools_stage_all
}
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+RRECOMMENDS_${PN} = " \
+ goffice-plugin-plot-barcol \
+ goffice-plugin-plot-distrib \
+ goffice-plugin-plot-pie \
+ goffice-plugin-plot-radar \
+ goffice-plugin-plot-surface \
+ goffice-plugin-plot-xy \
+ goffice-plugin-reg-linear \
+ goffice-plugin-reg-logfit \
+ goffice-plugin-smoothing \
+"
+
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_bindir}/* ${base_sbindir}/* \
+ ${base_libdir}/*${SOLIBS} \
+ ${datadir}/${PN} \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers"
+
PACKAGES_DYNAMIC = "goffice-plugin-*"
python populate_packages_prepend () {
- goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
}