aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/goffice_0.8.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-07 11:16:18 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-07 11:16:18 +0200
commit9dcb92605b704c6266a9914eebc1835600524cae (patch)
tree26ac224388defea45b3a01ac5313d24639933c1b /recipes/gnome/goffice_0.8.1.bb
parenta36bcd38d7fdd36395869ee8dcfcb40c8d46b951 (diff)
downloadopenembedded-9dcb92605b704c6266a9914eebc1835600524cae.tar.gz
goffic: add 0.8.1
Diffstat (limited to 'recipes/gnome/goffice_0.8.1.bb')
-rw-r--r--recipes/gnome/goffice_0.8.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/gnome/goffice_0.8.1.bb b/recipes/gnome/goffice_0.8.1.bb
new file mode 100644
index 0000000000..50c431c0d2
--- /dev/null
+++ b/recipes/gnome/goffice_0.8.1.bb
@@ -0,0 +1,44 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+
+DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
+
+inherit gnome pkgconfig
+
+SRC_URI += " file://c99math.patch;patch=1 \
+ file://nodolt.patch;patch=1 "
+
+SRC_URI[archive.md5sum] = "fdc43c5e04f6ead55bebc034c1d34296"
+SRC_URI[archive.sha256sum] = "9e2497956349fee8e6ec34a13160635455ead79a5118cbe61cb387e4cfd2b31e"
+
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+RRECOMMENDS_${PN} = " \
+ goffice-plugin-plot-barcol \
+ goffice-plugin-plot-distrib \
+ goffice-plugin-plot-pie \
+ goffice-plugin-plot-radar \
+ goffice-plugin-plot-surface \
+ goffice-plugin-plot-xy \
+ goffice-plugin-reg-linear \
+ goffice-plugin-reg-logfit \
+ goffice-plugin-smoothing \
+"
+
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_bindir}/* ${base_sbindir}/* \
+ ${base_libdir}/*${SOLIBS} \
+ ${datadir}/${PN} \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers"
+
+PACKAGES_DYNAMIC = "goffice-plugin-*"
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+