aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/system-tools-backends_2.10.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-01 14:38:48 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-01 19:59:09 +0200
commit980c3230ebfd9f1e7a28dc4b5758cddd5a19c33f (patch)
treec17288a369df851256dbd14ced661da487d91478 /recipes/gnome/system-tools-backends_2.10.0.bb
parent5a491e2f1fe84231c66f5871f5e3e8e6f6fa8063 (diff)
downloadopenembedded-980c3230ebfd9f1e7a28dc4b5758cddd5a19c33f.tar.gz
system-tools-backends: add 2.10.0
Diffstat (limited to 'recipes/gnome/system-tools-backends_2.10.0.bb')
-rw-r--r--recipes/gnome/system-tools-backends_2.10.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/gnome/system-tools-backends_2.10.0.bb b/recipes/gnome/system-tools-backends_2.10.0.bb
new file mode 100644
index 0000000000..393f971075
--- /dev/null
+++ b/recipes/gnome/system-tools-backends_2.10.0.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "gnome system tools backends"
+LICENSE = "GPL"
+
+DEPENDS = "dbus dbus-glib glib-2.0 policykit"
+
+# Shadow added so there is a full adduser/deluser
+# (Gnome images tend to pull in shadow anyway)
+RDEPENDS = "shadow"
+
+inherit gnome pkgconfig update-rc.d
+
+SRC_URI += " \
+ file://system-tools-backends \
+ "
+
+SRC_URI_append_angstrom = " \
+ file://add-angstrom-distro.patch;patch=1 \
+ "
+
+SRC_URI[archive.md5sum] = "01fd8fcfbe5f68492186404c96af915a"
+SRC_URI[archive.sha256sum] = "5afea48c0c195dd3b6e0b87a586c08bf614942d4bcb60449fd9f65d95418b60d"
+
+EXTRA_OECONF = " --with-net-dbus=${libdir}/perl5 "
+
+do_configure() {
+ sed -i -e 's:CC=$(CC):CC="$(CC)":g' ${S}/Net-DBus/Makefile.am
+ sed -i -e 's:CC=$(CC):CC="$(CC)":g' ${S}/Net-DBus/Makefile.in
+ gnu-configize
+ oe_runconf
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/system-tools-backends ${D}/${sysconfdir}/init.d/
+}
+
+INITSCRIPT_NAME = "system-tools-backends"
+INITSCRIPT_PARAMS = "start 50 2 3 4 5 . stop 70 1 ."
+
+FILES_${PN} += " ${sysconfdir}/dbus-1/system.d"
+FILES_${PN} += " ${libdir}/pkgconfig"
+FILES_${PN} += " ${datadir}/dbus-1/system-services"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/files"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/scripts"
+FILES_${PN} += " ${datadir}/polkit*"