aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-09-07 00:59:44 +0000
committerTom Rini <tom_rini@mentor.com>2010-09-30 14:03:08 -0700
commit1cdb3733cf2ad969a045686e7af5694bb078e653 (patch)
treef60ce86cbe8e3e8cbbab6fdf8264b177b8c7210a /recipes/gnome
parentee63893f3c1ca55fe58fb5332c59c44b68d823c3 (diff)
downloadopenembedded-1cdb3733cf2ad969a045686e7af5694bb078e653.tar.gz
gconf-native_2.6.1.bb: Converted to new style staging
* Converted do_stage to do_install. * Added NATIVE_INSTALL_WORKS = "1" * Added PR = "r1" Note: Not merging it into the non-native recipe as this is a dummy recipe and it does not need all the regular stuff. Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gconf-native_2.6.1.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes/gnome/gconf-native_2.6.1.bb b/recipes/gnome/gconf-native_2.6.1.bb
index 79163a42b1..f3f5fd8231 100644
--- a/recipes/gnome/gconf-native_2.6.1.bb
+++ b/recipes/gnome/gconf-native_2.6.1.bb
@@ -1,10 +1,14 @@
NOTE = "This is just a dummy package to get packages stop complaining about gconftool-2 \
which they are not using anyway... :D"
+PR = "r1"
+
inherit native
-do_stage() {
- echo "#!/bin/sh" >${STAGING_BINDIR}/gconftool-2
- chmod a+rx ${STAGING_BINDIR}/gconftool-2
+do_install() {
+ install -d ${D}${bindir}
+ echo "#!/bin/sh" >${D}${bindir}/gconftool-2
+ chmod a+rx ${D}${bindir}/gconftool-2
}
+NATIVE_INSTALL_WORKS = "1"