aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/gnome
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
openembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.bz2
openembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.zip
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/epiphany_2.21.92.bb2
-rw-r--r--recipes/gnome/epiphany_2.22.1.bb2
-rw-r--r--recipes/gnome/epiphany_2.24.0.bb2
-rw-r--r--recipes/gnome/epiphany_2.24.2.bb2
-rw-r--r--recipes/gnome/epiphany_2.27.1.bb2
-rw-r--r--recipes/gnome/epiphany_2.28.0.bb2
-rw-r--r--recipes/gnome/epiphany_2.30.0.bb2
-rw-r--r--recipes/gnome/epiphany_2.30.2.bb2
-rw-r--r--recipes/gnome/epiphany_svn.bb2
-rw-r--r--recipes/gnome/gconf_2.28.0.bb2
-rw-r--r--recipes/gnome/gedit_2.26.2.bb2
-rw-r--r--recipes/gnome/gedit_2.28.0.bb2
-rw-r--r--recipes/gnome/gedit_2.30.0.bb2
-rw-r--r--recipes/gnome/gnome-dvb-daemon_0.1.14.bb2
-rw-r--r--recipes/gnome/gnome-icon-theme_2.28.0.bb4
-rw-r--r--recipes/gnome/gnome-mime-data_2.18.0.bb2
-rw-r--r--recipes/gnome/gnome-mime-data_2.4.2.bb2
-rw-r--r--recipes/gnome/gnome-python_2.22.1.bb2
-rw-r--r--recipes/gnome/gnome-python_2.26.1.bb2
-rw-r--r--recipes/gnome/gnome-python_2.28.0.bb2
-rw-r--r--recipes/gnome/gnome-python_2.28.1.bb2
-rw-r--r--recipes/gnome/gnome-themes_2.28.0.bb2
-rw-r--r--recipes/gnome/gnome-vfs_2.22.0.bb2
-rw-r--r--recipes/gnome/gnome-vfs_2.24.1.bb2
-rw-r--r--recipes/gnome/libgsf_1.13.3.bb2
-rw-r--r--recipes/gnome/libgsf_1.14.16.bb2
-rw-r--r--recipes/gnome/libgsf_1.14.8.bb2
-rw-r--r--recipes/gnome/system-tools-backends_2.10.0.bb2
-rw-r--r--recipes/gnome/system-tools-backends_2.8.3.bb2
29 files changed, 30 insertions, 30 deletions
diff --git a/recipes/gnome/epiphany_2.21.92.bb b/recipes/gnome/epiphany_2.21.92.bb
index b9c66911e9..d39bf1eae1 100644
--- a/recipes/gnome/epiphany_2.21.92.bb
+++ b/recipes/gnome/epiphany_2.21.92.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
PR ="r2"
inherit gnome
diff --git a/recipes/gnome/epiphany_2.22.1.bb b/recipes/gnome/epiphany_2.22.1.bb
index 01c93b5111..eff32d759e 100644
--- a/recipes/gnome/epiphany_2.22.1.bb
+++ b/recipes/gnome/epiphany_2.22.1.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "libsoup-2.4 gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
PR = "r2"
diff --git a/recipes/gnome/epiphany_2.24.0.bb b/recipes/gnome/epiphany_2.24.0.bb
index c8e2d3f5d9..cfdb9e35dd 100644
--- a/recipes/gnome/epiphany_2.24.0.bb
+++ b/recipes/gnome/epiphany_2.24.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "libsoup-2.4 gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
PR = "r1"
inherit gnome
diff --git a/recipes/gnome/epiphany_2.24.2.bb b/recipes/gnome/epiphany_2.24.2.bb
index 5cee877c31..1fbe9bd9c7 100644
--- a/recipes/gnome/epiphany_2.24.2.bb
+++ b/recipes/gnome/epiphany_2.24.2.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "libsoup-2.4 gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
inherit gnome
diff --git a/recipes/gnome/epiphany_2.27.1.bb b/recipes/gnome/epiphany_2.27.1.bb
index 31dde7ed13..3d890bf964 100644
--- a/recipes/gnome/epiphany_2.27.1.bb
+++ b/recipes/gnome/epiphany_2.27.1.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "libsoup-2.4 gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
PR = "r1"
inherit gnome
diff --git a/recipes/gnome/epiphany_2.28.0.bb b/recipes/gnome/epiphany_2.28.0.bb
index 5497bea0ae..dc968d9fa0 100644
--- a/recipes/gnome/epiphany_2.28.0.bb
+++ b/recipes/gnome/epiphany_2.28.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "libsoup-2.4 gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
inherit gnome
diff --git a/recipes/gnome/epiphany_2.30.0.bb b/recipes/gnome/epiphany_2.30.0.bb
index 04bd10212b..97b4c5d1dd 100644
--- a/recipes/gnome/epiphany_2.30.0.bb
+++ b/recipes/gnome/epiphany_2.30.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "libsoup-2.4 gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
inherit gnome
diff --git a/recipes/gnome/epiphany_2.30.2.bb b/recipes/gnome/epiphany_2.30.2.bb
index 94fa7f0560..ba34d4d8e9 100644
--- a/recipes/gnome/epiphany_2.30.2.bb
+++ b/recipes/gnome/epiphany_2.30.2.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "libsoup-2.4 gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
inherit gnome
diff --git a/recipes/gnome/epiphany_svn.bb b/recipes/gnome/epiphany_svn.bb
index 6629c5b67b..63e2e3477d 100644
--- a/recipes/gnome/epiphany_svn.bb
+++ b/recipes/gnome/epiphany_svn.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "GNOME default webbrowser"
DEPENDS = "gnome-desktop gnome-vfs libgnomeui webkit-gtk iso-codes startup-notification"
-RDEPENDS = "gnome-vfs-plugin-http iso-codes"
+RDEPENDS_${PN} = "gnome-vfs-plugin-http iso-codes"
SRCREV = "7837"
PV = "2.20.1+svnr${SRCPV}"
diff --git a/recipes/gnome/gconf_2.28.0.bb b/recipes/gnome/gconf_2.28.0.bb
index e0aaffed7a..59e913fe84 100644
--- a/recipes/gnome/gconf_2.28.0.bb
+++ b/recipes/gnome/gconf_2.28.0.bb
@@ -12,7 +12,7 @@ SRC_URI[archive.sha256sum] = "d057dcfe2bfb2a80e592349c2a78d7dce12d19542aeced466c
PR="r1"
-RDEPENDS += "dbus-x11"
+RDEPENDS_${PN} += "dbus-x11"
EXTRA_OECONF = " --without-openldap --disable-gtk-doc --enable-gtk POLKIT_POLICY_FILE_VALIDATE=true"
diff --git a/recipes/gnome/gedit_2.26.2.bb b/recipes/gnome/gedit_2.26.2.bb
index 358653c8fe..64232505ac 100644
--- a/recipes/gnome/gedit_2.26.2.bb
+++ b/recipes/gnome/gedit_2.26.2.bb
@@ -3,7 +3,7 @@ SECTION = "x11/gnome"
LICENSE = "GPL"
DEPENDS = "iso-codes gnome-common glib-2.0 gtk+ gconf gtksourceview2"
-RDEPENDS += " gtksourceview2"
+RDEPENDS_${PN} += " gtksourceview2"
inherit gnome pkgconfig
diff --git a/recipes/gnome/gedit_2.28.0.bb b/recipes/gnome/gedit_2.28.0.bb
index af54ac29fa..9bf3841e42 100644
--- a/recipes/gnome/gedit_2.28.0.bb
+++ b/recipes/gnome/gedit_2.28.0.bb
@@ -3,7 +3,7 @@ SECTION = "x11/gnome"
LICENSE = "GPL"
DEPENDS = "iso-codes gnome-common glib-2.0 gtk+ gconf gtksourceview2"
-RDEPENDS += " gtksourceview2"
+RDEPENDS_${PN} += " gtksourceview2"
PR = "r2"
diff --git a/recipes/gnome/gedit_2.30.0.bb b/recipes/gnome/gedit_2.30.0.bb
index 9f4a8e16ce..50875abf56 100644
--- a/recipes/gnome/gedit_2.30.0.bb
+++ b/recipes/gnome/gedit_2.30.0.bb
@@ -3,7 +3,7 @@ SECTION = "x11/gnome"
LICENSE = "GPL"
DEPENDS = "iso-codes gnome-common glib-2.0 gtk+ gconf gtksourceview2"
-RDEPENDS += " gtksourceview2"
+RDEPENDS_${PN} += " gtksourceview2"
inherit gnome
SRC_URI[archive.md5sum] = "aebd49797406fdde7b25624b71990860"
diff --git a/recipes/gnome/gnome-dvb-daemon_0.1.14.bb b/recipes/gnome/gnome-dvb-daemon_0.1.14.bb
index 2df43df63a..ff0adf604e 100644
--- a/recipes/gnome/gnome-dvb-daemon_0.1.14.bb
+++ b/recipes/gnome/gnome-dvb-daemon_0.1.14.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "GNOME DVB Daemon is a daemon written in Vala based on GStreamer t
LICENSE = "GPLv3"
DEPENDS = "libxml2 python-dbus python-gst python-pygtk libgee vala-native gstreamer gst-plugins-good gst-plugins-bad glib-2.0 dbus-glib sqlite3 gst-rtsp"
-RDEPENDS = "python-dbus python-gst python-pygtk gst-plugin-dvb gst-fluendo-mpegdemux dvb-apps dvb-scan dvb-tzap dvb-czap dvbstream"
+RDEPENDS_${PN} = "python-dbus python-gst python-pygtk gst-plugin-dvb gst-fluendo-mpegdemux dvb-apps dvb-scan dvb-tzap dvb-czap dvbstream"
inherit gnome
diff --git a/recipes/gnome/gnome-icon-theme_2.28.0.bb b/recipes/gnome/gnome-icon-theme_2.28.0.bb
index 2561e6c53b..6493d9275b 100644
--- a/recipes/gnome/gnome-icon-theme_2.28.0.bb
+++ b/recipes/gnome/gnome-icon-theme_2.28.0.bb
@@ -2,8 +2,8 @@ SECTION = "x11/gnome"
LICENSE = "GPL"
DEPENDS = "icon-naming-utils-native glib-2.0 intltool-native"
-RDEPENDS = "hicolor-icon-theme"
-RRECOMMENDS = "librsvg-gtk"
+RDEPENDS_${PN} = "hicolor-icon-theme"
+RRECOMMENDS_${PN} = "librsvg-gtk"
PR = "r3"
diff --git a/recipes/gnome/gnome-mime-data_2.18.0.bb b/recipes/gnome/gnome-mime-data_2.18.0.bb
index 49aa5bf19a..3d8c5f5ef1 100644
--- a/recipes/gnome/gnome-mime-data_2.18.0.bb
+++ b/recipes/gnome/gnome-mime-data_2.18.0.bb
@@ -2,7 +2,7 @@ LICENSE = "GPL"
inherit gnome
DEPENDS += "shared-mime-info intltool-native"
-RDEPENDS = "shared-mime-info"
+RDEPENDS_${PN} = "shared-mime-info"
FILES_${PN}-dev += "${datadir}/pkgconfig/*.pc"
diff --git a/recipes/gnome/gnome-mime-data_2.4.2.bb b/recipes/gnome/gnome-mime-data_2.4.2.bb
index b16fca4696..d5c874b8bd 100644
--- a/recipes/gnome/gnome-mime-data_2.4.2.bb
+++ b/recipes/gnome/gnome-mime-data_2.4.2.bb
@@ -2,7 +2,7 @@ LICENSE = "GPL"
inherit gnome
DEPENDS += "libxml-parser-perl-native shared-mime-info intltool-native"
-RDEPENDS = "shared-mime-info"
+RDEPENDS_${PN} = "shared-mime-info"
PR = "r2"
diff --git a/recipes/gnome/gnome-python_2.22.1.bb b/recipes/gnome/gnome-python_2.22.1.bb
index fe3c00d6be..7316114b86 100644
--- a/recipes/gnome/gnome-python_2.22.1.bb
+++ b/recipes/gnome/gnome-python_2.22.1.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "GNOME Python miscellaneous bindings"
LICENSE = "LGPL"
DEPENDS = "libgnomeui pyorbit python-pygtk"
-RDEPENDS = "pyorbit"
+RDEPENDS_${PN} = "pyorbit"
PR = "r2"
diff --git a/recipes/gnome/gnome-python_2.26.1.bb b/recipes/gnome/gnome-python_2.26.1.bb
index f5fd3c3a1c..9b858c7c29 100644
--- a/recipes/gnome/gnome-python_2.26.1.bb
+++ b/recipes/gnome/gnome-python_2.26.1.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "GNOME Python miscellaneous bindings"
LICENSE = "LGPL"
DEPENDS = "libgnomeui pyorbit python-pygtk"
-RDEPENDS = "pyorbit"
+RDEPENDS_${PN} = "pyorbit"
PR = "r1"
diff --git a/recipes/gnome/gnome-python_2.28.0.bb b/recipes/gnome/gnome-python_2.28.0.bb
index 8278534fd3..fc217bc3fc 100644
--- a/recipes/gnome/gnome-python_2.28.0.bb
+++ b/recipes/gnome/gnome-python_2.28.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "GNOME Python miscellaneous bindings"
LICENSE = "LGPL"
DEPENDS = "libgnomeui pyorbit python-pygtk"
-RDEPENDS = "pyorbit"
+RDEPENDS_${PN} = "pyorbit"
PR = "r2"
diff --git a/recipes/gnome/gnome-python_2.28.1.bb b/recipes/gnome/gnome-python_2.28.1.bb
index 2bfaf4bd91..a9c5815773 100644
--- a/recipes/gnome/gnome-python_2.28.1.bb
+++ b/recipes/gnome/gnome-python_2.28.1.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "GNOME Python miscellaneous bindings"
LICENSE = "LGPL"
DEPENDS = "libgnomeui pyorbit python-pygtk"
-RDEPENDS = "pyorbit"
+RDEPENDS_${PN} = "pyorbit"
inherit gnome distutils-base pkgconfig
diff --git a/recipes/gnome/gnome-themes_2.28.0.bb b/recipes/gnome/gnome-themes_2.28.0.bb
index 732025929e..3de48d9661 100644
--- a/recipes/gnome/gnome-themes_2.28.0.bb
+++ b/recipes/gnome/gnome-themes_2.28.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "GNOME themes"
LICENSE = "GPL"
SECTION = "x11/gnome"
DEPENDS = "gtk-engines icon-naming-utils-native glib-2.0 intltool-native"
-RDEPENDS = "gnome-icon-theme"
+RDEPENDS_${PN} = "gnome-icon-theme"
EXTRA_OECONF = "--enable-all-themes --disable-hicolor-check"
diff --git a/recipes/gnome/gnome-vfs_2.22.0.bb b/recipes/gnome/gnome-vfs_2.22.0.bb
index d3d24b1f96..e0dc46fa15 100644
--- a/recipes/gnome/gnome-vfs_2.22.0.bb
+++ b/recipes/gnome/gnome-vfs_2.22.0.bb
@@ -1,6 +1,6 @@
LICENSE = "GPL"
DEPENDS = "libxml2 gconf gnutls avahi dbus dbus-glib bzip2 gnome-mime-data zlib"
-RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
+RRECOMMENDS_${PN} = "gnome-vfs-plugin-file shared-mime-info"
# Some legacy packages will require gnome-mime-data to be installed, but use of
# it is deprecated.
PR = "r1"
diff --git a/recipes/gnome/gnome-vfs_2.24.1.bb b/recipes/gnome/gnome-vfs_2.24.1.bb
index 3902e7774a..19104d479a 100644
--- a/recipes/gnome/gnome-vfs_2.24.1.bb
+++ b/recipes/gnome/gnome-vfs_2.24.1.bb
@@ -1,6 +1,6 @@
LICENSE = "GPL"
DEPENDS = "libxml2 gconf gnutls avahi dbus dbus-glib bzip2 gnome-mime-data zlib gtk-doc-native"
-RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
+RRECOMMENDS_${PN} = "gnome-vfs-plugin-file shared-mime-info"
# Some legacy packages will require gnome-mime-data to be installed, but use of
# it is deprecated.
PR = "r2"
diff --git a/recipes/gnome/libgsf_1.13.3.bb b/recipes/gnome/libgsf_1.13.3.bb
index f01c37fc3d..5bae38db34 100644
--- a/recipes/gnome/libgsf_1.13.3.bb
+++ b/recipes/gnome/libgsf_1.13.3.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
PR = "r1"
DEPENDS= "libxml2 glib-2.0 zlib gtk-doc libbonobo gnome-vfs"
-RDEPENDS = "gconf gnome-vfs"
+RDEPENDS_${PN} = "gconf gnome-vfs"
PACKAGES =+ "${PN}-gnome ${PN}-gnome-dev "
diff --git a/recipes/gnome/libgsf_1.14.16.bb b/recipes/gnome/libgsf_1.14.16.bb
index aa83dc84c7..239ab63daf 100644
--- a/recipes/gnome/libgsf_1.14.16.bb
+++ b/recipes/gnome/libgsf_1.14.16.bb
@@ -2,7 +2,7 @@ LICENSE = "GPL"
SECTION = "libs"
DEPENDS= "gtk+ libxml2 bzip2 glib-2.0 zlib gtk-doc libbonobo gnome-vfs"
-RDEPENDS = "gconf gnome-vfs"
+RDEPENDS_${PN} = "gconf gnome-vfs"
PACKAGES =+ "${PN}-gnome ${PN}-gnome-dev "
diff --git a/recipes/gnome/libgsf_1.14.8.bb b/recipes/gnome/libgsf_1.14.8.bb
index 9c39b47db0..49deeb9c19 100644
--- a/recipes/gnome/libgsf_1.14.8.bb
+++ b/recipes/gnome/libgsf_1.14.8.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
PR = "r0"
DEPENDS= "libxml2 bzip2 glib-2.0 zlib gtk-doc libbonobo gnome-vfs"
-RDEPENDS = "gconf gnome-vfs"
+RDEPENDS_${PN} = "gconf gnome-vfs"
PACKAGES =+ "${PN}-gnome ${PN}-gnome-dev "
diff --git a/recipes/gnome/system-tools-backends_2.10.0.bb b/recipes/gnome/system-tools-backends_2.10.0.bb
index ca4d1024b8..69f24d34ed 100644
--- a/recipes/gnome/system-tools-backends_2.10.0.bb
+++ b/recipes/gnome/system-tools-backends_2.10.0.bb
@@ -5,7 +5,7 @@ DEPENDS = "dbus dbus-glib glib-2.0 policykit"
# Shadow added so there is a full adduser/deluser
# (Gnome images tend to pull in shadow anyway)
-RDEPENDS = "shadow"
+RDEPENDS_${PN} = "shadow"
inherit gnome pkgconfig update-rc.d
diff --git a/recipes/gnome/system-tools-backends_2.8.3.bb b/recipes/gnome/system-tools-backends_2.8.3.bb
index d924d81a46..b555795a62 100644
--- a/recipes/gnome/system-tools-backends_2.8.3.bb
+++ b/recipes/gnome/system-tools-backends_2.8.3.bb
@@ -7,7 +7,7 @@ DEPENDS = "dbus dbus-glib glib-2.0 policykit"
# Shadow added so there is a full adduser/deluser
# (Gnome images tend to pull in shadow anyway)
-RDEPENDS = "shadow"
+RDEPENDS_${PN} = "shadow"
inherit gnome pkgconfig update-rc.d