aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-08 13:13:06 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-09 18:34:21 +0100
commitfda4472f284541b5378c87e4b5e8537c5e94069e (patch)
treed9b9db0678059c57fafab0d8b3d49296f66461f0 /recipes/gnome
parent11beaab12618068e59113980707cee85eeb3589f (diff)
downloadopenembedded-fda4472f284541b5378c87e4b5e8537c5e94069e.tar.gz
gnome-vfs 2.24.1: added patch from Debian to use new GnuTLS
Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-vfs/03_gnutls27.patch33
-rw-r--r--recipes/gnome/gnome-vfs_2.24.1.bb5
2 files changed, 36 insertions, 2 deletions
diff --git a/recipes/gnome/gnome-vfs/03_gnutls27.patch b/recipes/gnome/gnome-vfs/03_gnutls27.patch
new file mode 100644
index 0000000000..de7fafc287
--- /dev/null
+++ b/recipes/gnome/gnome-vfs/03_gnutls27.patch
@@ -0,0 +1,33 @@
+Debian #529827
+GNOME #574589
+Gentoo #253729
+Patch by Gilles Dartiguelongue, fixed for correctly setting have_ssl
+
+Allow gnome-vfs-2.24 to build with gnutls >= 2.7.0
+Use pkg-config in place of gnutls own macro since it's not present anymore.
+
+Index: gnome-vfs-2.24.2/configure.in
+===================================================================
+--- gnome-vfs-2.24.2.orig/configure.in 2009-04-20 12:46:46.000000000 +0200
++++ gnome-vfs-2.24.2/configure.in 2010-02-06 11:55:45.497282437 +0100
+@@ -668,14 +668,14 @@
+ AC_MSG_ERROR([*** Can't use both openssl and gnutls at the same time. Please pick one only. ***])
+ else
+ AC_CHECK_HEADER(gcrypt.h,, AC_MSG_ERROR([*** Need gcrypt.h to compile with GnuTLS support ***]))
+- AM_PATH_LIBGNUTLS(1.0.0, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
+- have_ssl=true])
++ PKG_CHECK_MODULES(LIBGNUTLS, gnutls >= 1.0.0, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
++ have_ssl=true])
+
+ if test "x${LIBGNUTLS_LIBS}" = "x"; then
+- AM_PATH_LIBGNUTLS(0.5.1, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
+- AC_DEFINE(GNUTLS_COMPAT, 1, [FIXME])
+- have_ssl=true],
+- AC_MSG_ERROR([Unable to find GNUTLS]))
++ PKG_CHECK_MODULES(LIBGNUTLS, gnutls >= 0.5.1, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
++ AC_DEFINE(GNUTLS_COMPAT, 1, [FIXME])
++ have_ssl=true],
++ AC_MSG_ERROR([Unable to find GNUTLS]))
+ fi
+ fi
+ fi
diff --git a/recipes/gnome/gnome-vfs_2.24.1.bb b/recipes/gnome/gnome-vfs_2.24.1.bb
index 511aabe5a7..367228da23 100644
--- a/recipes/gnome/gnome-vfs_2.24.1.bb
+++ b/recipes/gnome/gnome-vfs_2.24.1.bb
@@ -3,12 +3,13 @@ DEPENDS = "libxml2 gconf gnutls avahi dbus dbus-glib bzip2 gnome-mime-data zlib
RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
# Some legacy packages will require gnome-mime-data to be installed, but use of
# it is deprecated.
-PR = "r1"
+PR = "r2"
inherit gnome
SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1 \
- file://gnome-vfs-no-kerberos.patch;patch=1;pnum=0"
+ file://gnome-vfs-no-kerberos.patch;patch=1;pnum=0 \
+ file://03_gnutls27.patch;patch=1"
# This is to provide compatibility with the gnome-vfs DBus fork
PROVIDES = "gnome-vfs-plugin-dbus"