aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-28 11:18:14 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-28 11:18:14 +0100
commit9d5b227e6707347381884e1195077b2e5b6be9c9 (patch)
tree222a8a7f45382f1d00d6d7f6761f0cb450b8cc8d /recipes/gnome
parent75b82c6cc3c5f45e937968b593d669ac9fd7185f (diff)
downloadopenembedded-9d5b227e6707347381884e1195077b2e5b6be9c9.tar.gz
gnome-keyring: update to 2.26, adjust packaging accordingly
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-keyring_2.26.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-keyring_2.26.0.bb b/recipes/gnome/gnome-keyring_2.26.0.bb
new file mode 100644
index 0000000000..8259ac96ce
--- /dev/null
+++ b/recipes/gnome/gnome-keyring_2.26.0.bb
@@ -0,0 +1,28 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+
+inherit autotools gnome pkgconfig
+
+DEPENDS = "gtk+ libtasn1 libgcrypt"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/tasn.m4 acinclude.m4
+}
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
+PACKAGES =+ "gnome-keyring-pam-plugin"
+FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
+
+do_stage() {
+ autotools_stage_all
+}