aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-04-09 15:06:10 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-04-09 15:06:10 +0000
commita3cce179d238dc0a503ab80086796d4442a4dce2 (patch)
treed815f116e56208f9f23d78149817ebb54000b3b9 /recipes/gnome
parent71e5e4f51401bae4c63c712a9c15faad8270e4a1 (diff)
downloadopenembedded-a3cce179d238dc0a503ab80086796d4442a4dce2.tar.gz
gnome-panel: Compile idl files against STAGING_DIR_HOST.
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-panel/idl-sysroot.patch26
-rw-r--r--recipes/gnome/gnome-panel_2.26.0.bb5
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes/gnome/gnome-panel/idl-sysroot.patch b/recipes/gnome/gnome-panel/idl-sysroot.patch
new file mode 100644
index 0000000000..07e5ded6ec
--- /dev/null
+++ b/recipes/gnome/gnome-panel/idl-sysroot.patch
@@ -0,0 +1,26 @@
+Index: gnome-panel-2.26.0/gnome-panel/Makefile.am
+===================================================================
+--- gnome-panel-2.26.0.orig/gnome-panel/Makefile.am 2009-03-16 22:37:12.000000000 +0000
++++ gnome-panel-2.26.0/gnome-panel/Makefile.am 2009-04-09 14:39:02.000000000 +0000
+@@ -43,7 +43,7 @@
+ $(NULL)
+
+ $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
+- $(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
++ $(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
+
+ BUILT_SOURCES = \
+ $(CORBA_SRCLIST) \
+Index: gnome-panel-2.26.0/libpanel-applet/Makefile.am
+===================================================================
+--- gnome-panel-2.26.0.orig/libpanel-applet/Makefile.am 2009-03-16 22:37:13.000000000 +0000
++++ gnome-panel-2.26.0/libpanel-applet/Makefile.am 2009-04-09 14:51:18.000000000 +0000
+@@ -45,7 +45,7 @@
+ GNOME_Panel.h
+
+ $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
+- $(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
++ $(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
+
+ noinst_PROGRAMS = test-bonobo-applet
+
diff --git a/recipes/gnome/gnome-panel_2.26.0.bb b/recipes/gnome/gnome-panel_2.26.0.bb
index b2d615a750..608dd883c7 100644
--- a/recipes/gnome/gnome-panel_2.26.0.bb
+++ b/recipes/gnome/gnome-panel_2.26.0.bb
@@ -3,6 +3,8 @@ DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome
inherit gnome pkgconfig
+SRC_URI += "file://idl-sysroot.patch;patch=1"
+
do_configure_prepend() {
sed -i -e s:help:: ${S}/Makefile.am
}
@@ -14,7 +16,8 @@ FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
FILES_${PN} =+ "${datadir}/gnome* \
${datadir}/icons"
-EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+export SYSROOT = "${STAGING_DIR_HOST}"
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2 SYSROOT=${SYSROOT}"
EXTRA_OECONF = "--disable-scrollkeeper \
--disable-eds \
"