aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-02 18:34:09 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-02 18:34:09 +0200
commitda07a7a0c3d6a90a5ca4e0f7f2067a91a7500499 (patch)
treeecfd24b0dbdb874a02aedbbc22ec4626d5b32b93 /recipes/gnome
parent320a5e3633b4f91ad0d4bbd045f81ab563ec6aea (diff)
downloadopenembedded-da07a7a0c3d6a90a5ca4e0f7f2067a91a7500499.tar.gz
gnome-panel: update to 2.26
libgweather: update to 2.26
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-panel_2.26.0.bb24
-rw-r--r--recipes/gnome/libgweather_2.26.0.bb25
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-panel_2.26.0.bb b/recipes/gnome/gnome-panel_2.26.0.bb
new file mode 100644
index 0000000000..b2d615a750
--- /dev/null
+++ b/recipes/gnome/gnome-panel_2.26.0.bb
@@ -0,0 +1,24 @@
+LICENSE = "GPL"
+DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+
+inherit gnome pkgconfig
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/icons"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+EXTRA_OECONF = "--disable-scrollkeeper \
+ --disable-eds \
+ "
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/gnome/libgweather_2.26.0.bb b/recipes/gnome/libgweather_2.26.0.bb
new file mode 100644
index 0000000000..f36dbbdec7
--- /dev/null
+++ b/recipes/gnome/libgweather_2.26.0.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+DEPENDS = "libgnome libsoup-2.4 gtk+"
+
+inherit gnome
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/icons"
+
+do_configure_prepend() {
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_stage() {
+ autotools_stage_all
+}