aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2011-04-03 19:58:07 -0700
committerKoen Kooi <koen@openembedded.org>2011-05-08 20:24:28 +0200
commitf4186a27499c788e45e1a809c5cc6585f9b57237 (patch)
tree7d41e1822eadcf80b9e20554bb45750689593c08 /recipes/gnome
parent643f493dbab6576cd49e91861e18c5adcc6139e0 (diff)
downloadopenembedded-f4186a27499c788e45e1a809c5cc6585f9b57237.tar.gz
gnome-media: Add recipe for 2.32.0
Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-media_2.32.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-media_2.32.0.bb b/recipes/gnome/gnome-media_2.32.0.bb
new file mode 100644
index 0000000000..8a71aa23c5
--- /dev/null
+++ b/recipes/gnome/gnome-media_2.32.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "GNOME Media Tools"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gnome-doc-utils gconf glib-2.0 gstreamer gst-plugins-base gtk+ gdk-pixbuf-csource-native libcanberra libglade libgnomeui libunique libxml2"
+# optional for volume control:
+DEPENDS += "pulseaudio"
+
+inherit gnome
+
+EXTRA_OECONF += "--disable-static --disable-gtk-doc"
+
+# FIXME: Native doc processing with xsltproc using docbook needs additional work:
+do_configure_prepend() {
+ sed -i 's/^\(SUBDIRS = .*\)\(doc\|help\)/\1/' */Makefile.am
+}
+
+FILES_${PN} += "${libdir}/libglade/2.0/libgnome-media-profiles.so \
+ ${datadir}/gstreamer-properties \
+ ${datadir}/gnome-sound-recorder"
+
+FILES_${PN}-dbg += "${libdir}/libglade/2.0/.debug"
+
+SRC_URI[archive.md5sum] = "06fc8c67add34c98bc484e0dbc404d41"
+SRC_URI[archive.sha256sum] = "2b0ad4decd75406398f46e82a170e53bcbc6e1bdc3363f03a07b00f59c2fe5e6"
+