aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2011-04-16 20:17:31 -0700
committerKoen Kooi <koen@openembedded.org>2011-05-08 20:24:33 +0200
commit313644a0157bfc43ec64a32a992a76607d3addce (patch)
treec75a7da1370e0543faa859f2fa55bdcb532b57a7 /recipes/gnome
parent7757b121cc44c9594a5cc75b69cd6dff40e8f7a2 (diff)
downloadopenembedded-313644a0157bfc43ec64a32a992a76607d3addce.tar.gz
gnome-keyring: Add recipe for 2.32.1
Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-keyring_2.32.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-keyring_2.32.1.bb b/recipes/gnome/gnome-keyring_2.32.1.bb
new file mode 100644
index 0000000000..9aa4fe348b
--- /dev/null
+++ b/recipes/gnome/gnome-keyring_2.32.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNOME security credential management"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "libgnome-keyring gtk+-native libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
+RDEPENDS = "libgnome-keyring"
+PR = "r1"
+
+inherit gnome pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security"
+
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service file://libtool.workarround.patch"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/tasn.m4 acinclude.m4
+}
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr ${datadir}/GConf/gsettings ${datadir}/glib-2.0/schemas"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
+
+PACKAGES =+ "gnome-keyring-pam-plugin"
+FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
+
+SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
+SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9"
+