summaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-05 09:49:16 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-05 09:49:16 +0100
commit28014bdfa3e88b561189ef134bb175dd381bc720 (patch)
tree9bbf29f2ec8dedbf5f2aec4c2bf7cb291ee4060f /recipes/gnome
parent2cdfa33e57e80ac236274343a5635ce9a6de380e (diff)
downloadopenembedded-28014bdfa3e88b561189ef134bb175dd381bc720.tar.gz
gnome-python-extras: adjust to pygtk -> pygobject codegen move
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-python-extras_2.25.3.bb25
1 files changed, 19 insertions, 6 deletions
diff --git a/recipes/gnome/gnome-python-extras_2.25.3.bb b/recipes/gnome/gnome-python-extras_2.25.3.bb
index cf3d84e9af..225e9832b8 100644
--- a/recipes/gnome/gnome-python-extras_2.25.3.bb
+++ b/recipes/gnome/gnome-python-extras_2.25.3.bb
@@ -1,21 +1,34 @@
LICENSE = "GPL/LGPL"
DEPENDS = "python-pygtk libwnck"
-inherit gnome distutils-base
+PR = "r1"
+
+inherit distutils-base gnome
SRC_URI += "file://acinclude.m4"
-EXTRA_OECONF = "--with-python-includes=${STAGING_INCDIR}/../"
+EXTRA_OECONF = "--with-python-includes=${STAGING_INCDIR}/../ ac_cv_path_PYGTK_CODEGEN=${STAGING_DATADIR}/pygobject/2.0/codegen/codegen.py"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
}
do_configure_prepend() {
- sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
- -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
- -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes/\":g \
- ${S}/configure.ac
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ export PYGTK_CODEGEN="${STAGING_DATADIR}/pygobject/2.0/codegen/codegen.py"
+ sed -i \
+ -e s:'`$PKG_CONFIG --variable defsdir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=pygtkincludedir pygobject-2.0`':\"${STAGING_INCDIR}/pygtk-2.0\":g \
+ -e s:'`$PKG_CONFIG --variable=datadir pygobject-2.0`':\"${STAGING_DATADIR}\":g \
+ -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ -e s:'`$PKG_CONFIG --variable=codegendir pygtk-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \
+ -e 's:PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION":PYTHON_CFLAGS="-I${STAGING_INCDIR}/python$PYTHON_VERSION":g' \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes/\":g \
+ ${S}/configure.ac
}
AUTOTOOLS_STAGE_PKGCONFIG = "1"