summaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-05 13:35:50 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-05 13:35:50 +0100
commit2b0e95fd5d1a4610f4bdc5b929500472562f7b37 (patch)
tree3bbb3fd129e88d80b67b642fd917531e810b5331 /recipes/gnome
parentf389ecae0287535b6df5cc1a8e2c49e16cf7efed (diff)
downloadopenembedded-2b0e95fd5d1a4610f4bdc5b929500472562f7b37.tar.gz
gdm: tweak initscript and add grep to depends since busybox grep doesn't do -w
Diffstat (limited to 'recipes/gnome')
-rwxr-xr-xrecipes/gnome/gdm-2.28.0/gdm11
-rw-r--r--recipes/gnome/gdm_2.28.0.bb4
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/gnome/gdm-2.28.0/gdm b/recipes/gnome/gdm-2.28.0/gdm
index fed9c06ad7..22ee7d461d 100755
--- a/recipes/gnome/gdm-2.28.0/gdm
+++ b/recipes/gnome/gdm-2.28.0/gdm
@@ -32,10 +32,21 @@ DEFAULT_DISPLAY_MANAGER_FILE=/etc/X11/default-display-manager
case "$1" in
start)
# make needed directories in volatile
+
+ if [ -e /var/log/gdm ] ; then
+ rm -rf /var/log/gdm
+ fi
+
mkdir -m 01770 /var/log/gdm
chown gdm:gdm /var/log/gdm
+
+ if [ -e /tmp/.ICE-unix \ ; then
+ rm -rf /tmp/.ICE-unix
+ fi
+
mkdir -m 01777 /tmp/.ICE-unix
chown root:root /tmp/.ICE-unix
+
CONFIGURED_DAEMON=$(basename "$(cat $DEFAULT_DISPLAY_MANAGER_FILE 2> /dev/null)")
if grep -wqs text /proc/cmdline; then
echo "Not starting GNOME Display Manager (gdm); found 'text' in kernel commandline."
diff --git a/recipes/gnome/gdm_2.28.0.bb b/recipes/gnome/gdm_2.28.0.bb
index 683773a3ab..ac5d52505d 100644
--- a/recipes/gnome/gdm_2.28.0.bb
+++ b/recipes/gnome/gdm_2.28.0.bb
@@ -3,10 +3,12 @@ LICENSE = "GPL"
DEPENDS = "libcanberra libxklavier grep consolekit libpam gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl xrdb"
-PR = "r1"
+PR = "r2"
inherit gnome update-rc.d
+RDEPENDS_${PN} += "grep"
+
SRC_URI += " \
file://cross-xdetection.diff;patch=1 \
file://%gconf-tree.xml \