summaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-26 09:26:55 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-26 11:01:13 +0100
commit35c50ca5d1ba2effc263584b3cd1e8eb06ec4578 (patch)
tree9b54934498ec8834d1dc007362c5e360909582aa /recipes/gnome
parent5ea98f53845183209f5fe6d9524a69114b2a93a7 (diff)
downloadopenembedded-35c50ca5d1ba2effc263584b3cd1e8eb06ec4578.tar.gz
gnome-keyring: remove trailing / for target directories
* issue for combination of automake-1.11 and libtool-2.2.6 * http://www.mail-archive.com/automake@gnu.org/msg15171.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-keyring/libtool.workarround.patch48
-rw-r--r--recipes/gnome/gnome-keyring_2.28.2.bb5
2 files changed, 51 insertions, 2 deletions
diff --git a/recipes/gnome/gnome-keyring/libtool.workarround.patch b/recipes/gnome/gnome-keyring/libtool.workarround.patch
new file mode 100644
index 0000000000..5dcc43ea31
--- /dev/null
+++ b/recipes/gnome/gnome-keyring/libtool.workarround.patch
@@ -0,0 +1,48 @@
+diff -uNr gnome-keyring-2.28.2.orig//pkcs11/roots-store/Makefile.am gnome-keyring-2.28.2/pkcs11/roots-store/Makefile.am
+--- gnome-keyring-2.28.2.orig//pkcs11/roots-store/Makefile.am 2010-03-26 09:01:11.000000000 +0100
++++ gnome-keyring-2.28.2/pkcs11/roots-store/Makefile.am 2010-03-26 09:00:33.000000000 +0100
+@@ -22,7 +22,7 @@
+ # ------------------------------------------------------------------------------
+ # The standalone module
+
+-moduledir = $(libdir)/gnome-keyring/standalone/
++moduledir = $(libdir)/gnome-keyring/standalone
+
+ module_LTLIBRARIES = \
+ gck-roots-store-standalone.la
+diff -uNr gnome-keyring-2.28.2/pkcs11/ssh-store/Makefile.am gnome-keyring-2.28.2.new/pkcs11/ssh-store/Makefile.am
+--- gnome-keyring-2.28.2/pkcs11/ssh-store/Makefile.am 2009-11-10 03:43:05.000000000 +0100
++++ gnome-keyring-2.28.2.new/pkcs11/ssh-store/Makefile.am 2010-03-26 09:04:22.000000000 +0100
+@@ -24,7 +24,7 @@
+ # ------------------------------------------------------------------------------
+ # The standalone module
+
+-moduledir = $(libdir)/gnome-keyring/devel/
++moduledir = $(libdir)/gnome-keyring/devel
+
+ module_LTLIBRARIES = \
+ gck-ssh-store-standalone.la
+diff -uNr gnome-keyring-2.28.2/pkcs11/user-store/Makefile.am gnome-keyring-2.28.2.new/pkcs11/user-store/Makefile.am
+--- gnome-keyring-2.28.2/pkcs11/user-store/Makefile.am 2009-12-14 15:38:07.000000000 +0100
++++ gnome-keyring-2.28.2.new/pkcs11/user-store/Makefile.am 2010-03-26 09:09:59.000000000 +0100
+@@ -24,7 +24,7 @@
+ # ------------------------------------------------------------------------------
+ # The standalone module
+
+-moduledir = $(libdir)/gnome-keyring/devel/
++moduledir = $(libdir)/gnome-keyring/devel
+
+ module_LTLIBRARIES = \
+ gck-user-store-standalone.la
+diff -uNr gnome-keyring-2.28.2/pkcs11/rpc-layer/Makefile.am gnome-keyring-2.28.2.new/pkcs11/rpc-layer/Makefile.am
+--- gnome-keyring-2.28.2/pkcs11/rpc-layer/Makefile.am 2009-11-10 03:45:14.000000000 +0100
++++ gnome-keyring-2.28.2.new/pkcs11/rpc-layer/Makefile.am 2010-03-26 09:10:40.000000000 +0100
+@@ -34,7 +34,7 @@
+ # ------------------------------------------------------------------------------
+ # The module code, built as the public gnome-keyring module
+
+-moduledir = $(libdir)/gnome-keyring/
++moduledir = $(libdir)/gnome-keyring
+
+ module_LTLIBRARIES = \
+ gnome-keyring-pkcs11.la
diff --git a/recipes/gnome/gnome-keyring_2.28.2.bb b/recipes/gnome/gnome-keyring_2.28.2.bb
index c8a79d4aa1..3a1e12dfe5 100644
--- a/recipes/gnome/gnome-keyring_2.28.2.bb
+++ b/recipes/gnome/gnome-keyring_2.28.2.bb
@@ -2,12 +2,13 @@ DESCRIPTION = "GNOME security credential management"
LICENSE = "GPL"
SECTION = "x11/gnome"
DEPENDS = " gtk+-native libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
+PR = "r1"
inherit gnome pkgconfig
-EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security/"
+EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security"
-SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service file://libtool.workarround.patch;patch=1"
do_configure_prepend() {
cp ${WORKDIR}/tasn.m4 acinclude.m4