aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuradio
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2009-07-09 15:42:59 -0400
committerPhilip Balister <philip@balister.org>2009-07-09 15:42:59 -0400
commit1277272b839bf6e0209fc8b1aa36f9399fac596b (patch)
treeda83c4c52cd60826cd1401e8faa939780da1ae2e /recipes/gnuradio
parent415f42241b735a11f74c3b6e9a94dde58f12e524 (diff)
downloadopenembedded-1277272b839bf6e0209fc8b1aa36f9399fac596b.tar.gz
gnuradio : Add bb file for GNURadio 3.2.1.
Diffstat (limited to 'recipes/gnuradio')
-rw-r--r--recipes/gnuradio/gnuradio_3.2.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gnuradio/gnuradio_3.2.1.bb b/recipes/gnuradio/gnuradio_3.2.1.bb
new file mode 100644
index 0000000000..649df09e0a
--- /dev/null
+++ b/recipes/gnuradio/gnuradio_3.2.1.bb
@@ -0,0 +1,22 @@
+require gnuradio.inc
+
+DEPENDS += " gsl "
+
+PR = "${INC_PR}.1"
+
+S = "${WORKDIR}/gnuradio-3.2.1"
+
+EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable--usrp2"
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.1.tar.gz \
+ file://no-usrp2.patch;patch=1 \
+ file://gnuradio-neon.patch;patch=1;pnum=0 \
+ ${SOURCEFORGE_MIRROR}/libusb/libusb-0.1.12.tar.gz \
+"
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ gnuradio-core/gnuradio-core.pc
+}
+