aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnutls
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-24 09:30:08 +1030
committerKhem Raj <raj.khem@gmail.com>2010-11-24 14:27:15 -0800
commit46b868729005cb3012deff59a33287e55aa3dd56 (patch)
treeb7ec7464b23e352e8623e4a6d2d97faf49b778f8 /recipes/gnutls
parentb5597a3e3031f3b9bc548f32945a3ea6b88008a8 (diff)
downloadopenembedded-46b868729005cb3012deff59a33287e55aa3dd56.tar.gz
gnutls_2.10.2.bb: Fix parallel build failure.
In file included from core.c:32: enums.h:3:1: error: unterminated #ifndef In file included from core.c:40: enum-map.i.c:867:1: error: unterminated argument list invoking macro "SCM_SMOB_PRINT" In file included from errors.c:28: enums.h:3:1: error: unterminated #ifndef Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gnutls')
-rw-r--r--recipes/gnutls/gnutls-2.10.2/parallel-build.patch15
-rw-r--r--recipes/gnutls/gnutls_2.10.2.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/gnutls/gnutls-2.10.2/parallel-build.patch b/recipes/gnutls/gnutls-2.10.2/parallel-build.patch
new file mode 100644
index 0000000000..d170c4f02a
--- /dev/null
+++ b/recipes/gnutls/gnutls-2.10.2/parallel-build.patch
@@ -0,0 +1,15 @@
+Upstream: http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commit;h=23f761290ca6f905f062d2de217acb012e5a38b2
+
+diff --git a/guile/src/Makefile.am.orig b/guile/src/Makefile.am
+index e8e81b1..2ee1297 100644
+--- a/guile/src/Makefile.am.orig
++++ b/guile/src/Makefile.am
+@@ -122,7 +122,7 @@ extra-smob-types.i.c: $(srcdir)/make-smob-types.scm
+ snarfcppopts = $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
+ $(CFLAGS) $(AM_CFLAGS) $(GUILE_CFLAGS)
+
+-.c.x:
++.c.x: $(BUILT_SOURCES)
+ $(guile_snarf) -o $@ $< $(snarfcppopts)
+
+ # Target used by doc/Makefile, to create all built sources necessary
diff --git a/recipes/gnutls/gnutls_2.10.2.bb b/recipes/gnutls/gnutls_2.10.2.bb
index 97a3c117df..8af70ec59f 100644
--- a/recipes/gnutls/gnutls_2.10.2.bb
+++ b/recipes/gnutls/gnutls_2.10.2.bb
@@ -1,6 +1,6 @@
require gnutls.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
LICENSE_${PN}-extra = "GPLv3"
@@ -9,6 +9,7 @@ EXTRA_OECONF += " --without-libgcrypt-prefix "
SRC_URI += "file://gettextize-with-gettext-0.18.patch \
file://gnutls-openssl.patch \
file://gnutls-replace-siginterrupt.patch \
+ file://parallel-build.patch \
"
do_configure_prepend() {