aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnutls
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gnutls
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gnutls')
-rw-r--r--recipes/gnutls/gnutls-1.6.3/configure_madness.patch49
-rw-r--r--recipes/gnutls/gnutls-1.6.3/gnutls-openssl.patch124
-rw-r--r--recipes/gnutls/gnutls-1.6.3/gnutls-texinfo-euro.patch16
-rw-r--r--recipes/gnutls/gnutls-2.4.2/configure_madness.patch57
-rw-r--r--recipes/gnutls/gnutls-2.4.2/gnutls-openssl.patch124
-rw-r--r--recipes/gnutls/gnutls-2.4.2/gnutls-replace-siginterrupt.patch37
-rw-r--r--recipes/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch16
-rw-r--r--recipes/gnutls/gnutls.inc36
-rw-r--r--recipes/gnutls/gnutls_1.4.5.bb8
-rw-r--r--recipes/gnutls/gnutls_1.6.3.bb14
-rw-r--r--recipes/gnutls/gnutls_2.4.2.bb10
-rw-r--r--recipes/gnutls/libtasn1_1.7.bb15
12 files changed, 506 insertions, 0 deletions
diff --git a/recipes/gnutls/gnutls-1.6.3/configure_madness.patch b/recipes/gnutls/gnutls-1.6.3/configure_madness.patch
new file mode 100644
index 0000000000..bdee81cc54
--- /dev/null
+++ b/recipes/gnutls/gnutls-1.6.3/configure_madness.patch
@@ -0,0 +1,49 @@
+Index: gnutls-1.6.3/configure.in
+===================================================================
+--- gnutls-1.6.3.orig/configure.in 2008-02-29 09:58:12.000000000 +0000
++++ gnutls-1.6.3/configure.in 2008-02-29 09:58:15.000000000 +0000
+@@ -574,13 +574,13 @@
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+
+-LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
+-LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}"
++LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
++LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS"
+ AC_SUBST(LIBGNUTLS_LIBS)
+ AC_SUBST(LIBGNUTLS_CFLAGS)
+
+-LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
+-LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS -I${includedir}"
++LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
++LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS"
+ AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
+ AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
+ export ac_full
+Index: gnutls-1.6.3/lib/gnutls.pc.in
+===================================================================
+--- gnutls-1.6.3.orig/lib/gnutls.pc.in 2008-02-29 09:58:23.000000000 +0000
++++ gnutls-1.6.3/lib/gnutls.pc.in 2008-02-29 09:58:49.000000000 +0000
+@@ -18,6 +18,7 @@
+ Name: GnuTLS
+ Description: Transport Security Layer implementation for the GNU system
+ Version: @VERSION@
++Requires.private: gcrypt
+ Libs: -L${libdir} -lgnutls
+-Libs.private: @LIBGNUTLS_LIBS@
++Libs.private: -L${libdir} -lgnutls
+ Cflags: -I${includedir}
+Index: gnutls-1.6.3/libextra/gnutls-extra.pc.in
+===================================================================
+--- gnutls-1.6.3.orig/libextra/gnutls-extra.pc.in 2008-02-29 09:59:02.000000000 +0000
++++ gnutls-1.6.3/libextra/gnutls-extra.pc.in 2008-02-29 09:59:31.000000000 +0000
+@@ -18,7 +18,8 @@
+ Name: GnuTLS-extra
+ Description: Additional add-ons for GnuTLS licensed under GPL
+ Requires: gnutls
++Requires.private: gnutls
+ Version: @VERSION@
+ Libs: -L${libdir} -lgnutls-extra
+-Libs.private: @LIBGNUTLS_EXTRA_LIBS@
++Libs.private: -L${libdir} -lgnutls-extra
+ Cflags: -I${includedir}
diff --git a/recipes/gnutls/gnutls-1.6.3/gnutls-openssl.patch b/recipes/gnutls/gnutls-1.6.3/gnutls-openssl.patch
new file mode 100644
index 0000000000..e2c189592f
--- /dev/null
+++ b/recipes/gnutls/gnutls-1.6.3/gnutls-openssl.patch
@@ -0,0 +1,124 @@
+Index: gnutls-1.6.0/libextra/gnutls_openssl.c
+===================================================================
+--- gnutls-1.6.0.orig/libextra/gnutls_openssl.c 2006-08-13 22:34:09.000000000 +0200
++++ gnutls-1.6.0/libextra/gnutls_openssl.c 2006-12-12 15:07:59.002227000 +0100
+@@ -256,12 +256,17 @@
+ ssl->rfd = (gnutls_transport_ptr_t) - 1;
+ ssl->wfd = (gnutls_transport_ptr_t) - 1;
+
++ ssl->ssl_peek_buffer = NULL;
++ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
++
+ return ssl;
+ }
+
+ void
+ SSL_free (SSL * ssl)
+ {
++ if (ssl->ssl_peek_buffer)
++ free(ssl->ssl_peek_buffer);
+ gnutls_certificate_free_credentials (ssl->gnutls_cred);
+ gnutls_deinit (ssl->gnutls_state);
+ free (ssl);
+@@ -285,6 +290,7 @@
+ SSL_set_fd (SSL * ssl, int fd)
+ {
+ gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
++ ssl->rfd = ssl->wfd = fd;
+ return 1;
+ }
+
+@@ -310,6 +316,17 @@
+ return 1;
+ }
+
++int SSL_get_rfd(SSL *ssl)
++{
++ return ssl->rfd;
++}
++
++int SSL_get_wfd(SSL *ssl)
++{
++ return ssl->wfd;
++}
++
++
+ void
+ SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
+ {
+@@ -325,6 +342,8 @@
+ int
+ SSL_pending (SSL * ssl)
+ {
++ if (ssl->ssl_peek_avail)
++ return ssl->ssl_peek_avail;
+ return gnutls_record_check_pending (ssl->gnutls_state);
+ }
+
+@@ -480,11 +499,50 @@
+ return 1;
+ }
+
++int SSL_peek(SSL *ssl, void *buf, int len)
++{
++ if (len > ssl->ssl_peek_buffer_size) {
++ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
++ ssl->ssl_peek_buffer_size = len;
++ }
++
++ if (ssl->ssl_peek_avail == 0) {
++
++ int ret;
++
++ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
++ ssl->last_error = ret;
++
++ if (ret > 0)
++ ssl->ssl_peek_avail += ret;
++ }
++
++ if (len > ssl->ssl_peek_avail)
++ len = ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, len);
++
++ return len;
++}
++
+ int
+ SSL_read (SSL * ssl, void *buf, int len)
+ {
+ int ret;
+
++ if (ssl->ssl_peek_avail) {
++ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, n);
++
++ if (ssl->ssl_peek_avail > n)
++ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
++
++ ssl->ssl_peek_avail -= n;
++
++ return n;
++ }
++
+ ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
+ ssl->last_error = ret;
+
+Index: gnutls-1.6.0/includes/gnutls/openssl.h
+===================================================================
+--- gnutls-1.6.0.orig/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100
++++ gnutls-1.6.0/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100
+@@ -164,6 +164,11 @@
+
+ gnutls_transport_ptr_t rfd;
+ gnutls_transport_ptr_t wfd;
++
++ char *ssl_peek_buffer;
++ size_t ssl_peek_buffer_size;
++ size_t ssl_peek_avail;
++
+ };
+
+ #define rbio gnutls_state
diff --git a/recipes/gnutls/gnutls-1.6.3/gnutls-texinfo-euro.patch b/recipes/gnutls/gnutls-1.6.3/gnutls-texinfo-euro.patch
new file mode 100644
index 0000000000..e2a2762424
--- /dev/null
+++ b/recipes/gnutls/gnutls-1.6.3/gnutls-texinfo-euro.patch
@@ -0,0 +1,16 @@
+The version of texinfo in Debian Sarge does not understand the @euro{} command.
+This patch replaces the @euro{} command with the word "euro".
+
+--- gnutls-1.3.5/doc/signatures.texi.orig 2006-04-26 08:06:40.918268000 +0930
++++ gnutls-1.3.5/doc/signatures.texi 2006-04-26 08:06:52.446515440 +0930
+@@ -11,8 +11,8 @@
+ long as it is difficult enough to generate two different messages with
+ the same hash algorithm output. In that case the same signature could
+ be used as a proof for both messages. Nobody wants to sign an innocent
+-message of donating 1 @euro{} to Greenpeace and find out that he
+-donated 1.000.000 @euro{} to Bad Inc.
++message of donating 1 euro to Greenpeace and find out that he
++donated 1.000.000 euro to Bad Inc.
+
+ For a hash algorithm to be called cryptographic the following three
+ requirements must hold
diff --git a/recipes/gnutls/gnutls-2.4.2/configure_madness.patch b/recipes/gnutls/gnutls-2.4.2/configure_madness.patch
new file mode 100644
index 0000000000..19b6b498b4
--- /dev/null
+++ b/recipes/gnutls/gnutls-2.4.2/configure_madness.patch
@@ -0,0 +1,57 @@
+---
+ configure.in | 8 ++++----
+ lib/gnutls.pc.in | 3 ++-
+ libextra/gnutls-extra.pc.in | 3 ++-
+ 3 files changed, 8 insertions(+), 6 deletions(-)
+
+--- gnutls-2.4.0.orig/configure.in
++++ gnutls-2.4.0/configure.in
+@@ -637,17 +637,17 @@ AC_MSG_RESULT([***
+ *** Detecting options for shared libraries...
+ ])
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+
+-LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
+-LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}"
++LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
++LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS"
+ AC_SUBST(LIBGNUTLS_LIBS)
+ AC_SUBST(LIBGNUTLS_CFLAGS)
+
+-LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
+-LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}"
++LIBGNUTLS_EXTRA_LIBS=" -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
++LIBGNUTLS_EXTRA_CFLAGS=""
+ AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
+ AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
+ export ac_full
+
+ AM_CFLAGS="${AM_CFLAGS} ${LIBGCRYPT_CFLAGS}"
+--- gnutls-2.4.0.orig/lib/gnutls.pc.in
++++ gnutls-2.4.0/lib/gnutls.pc.in
+@@ -16,8 +16,9 @@ libdir=@libdir@
+ includedir=@includedir@
+
+ Name: GnuTLS
+ Description: Transport Security Layer implementation for the GNU system
+ Version: @VERSION@
++Requires.private: libgcrypt
+ Libs: -L${libdir} -lgnutls
+-Libs.private: @LIBGNUTLS_LIBS@
++Libs.private: -L${libdir} -lgnutls
+ Cflags: -I${includedir}
+--- gnutls-2.4.0.orig/libextra/gnutls-extra.pc.in
++++ gnutls-2.4.0/libextra/gnutls-extra.pc.in
+@@ -16,9 +16,10 @@ libdir=@libdir@
+ includedir=@includedir@
+
+ Name: GnuTLS-extra
+ Description: Additional add-ons for GnuTLS licensed under GPL
+ Requires: gnutls
++Requires.private: gnutls
+ Version: @VERSION@
+ Libs: -L${libdir} -lgnutls-extra
+-Libs.private: @LIBGNUTLS_EXTRA_LIBS@
++Libs.private: -L${libdir} -lgnutls-extra
+ Cflags: -I${includedir}
diff --git a/recipes/gnutls/gnutls-2.4.2/gnutls-openssl.patch b/recipes/gnutls/gnutls-2.4.2/gnutls-openssl.patch
new file mode 100644
index 0000000000..e2c189592f
--- /dev/null
+++ b/recipes/gnutls/gnutls-2.4.2/gnutls-openssl.patch
@@ -0,0 +1,124 @@
+Index: gnutls-1.6.0/libextra/gnutls_openssl.c
+===================================================================
+--- gnutls-1.6.0.orig/libextra/gnutls_openssl.c 2006-08-13 22:34:09.000000000 +0200
++++ gnutls-1.6.0/libextra/gnutls_openssl.c 2006-12-12 15:07:59.002227000 +0100
+@@ -256,12 +256,17 @@
+ ssl->rfd = (gnutls_transport_ptr_t) - 1;
+ ssl->wfd = (gnutls_transport_ptr_t) - 1;
+
++ ssl->ssl_peek_buffer = NULL;
++ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
++
+ return ssl;
+ }
+
+ void
+ SSL_free (SSL * ssl)
+ {
++ if (ssl->ssl_peek_buffer)
++ free(ssl->ssl_peek_buffer);
+ gnutls_certificate_free_credentials (ssl->gnutls_cred);
+ gnutls_deinit (ssl->gnutls_state);
+ free (ssl);
+@@ -285,6 +290,7 @@
+ SSL_set_fd (SSL * ssl, int fd)
+ {
+ gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
++ ssl->rfd = ssl->wfd = fd;
+ return 1;
+ }
+
+@@ -310,6 +316,17 @@
+ return 1;
+ }
+
++int SSL_get_rfd(SSL *ssl)
++{
++ return ssl->rfd;
++}
++
++int SSL_get_wfd(SSL *ssl)
++{
++ return ssl->wfd;
++}
++
++
+ void
+ SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
+ {
+@@ -325,6 +342,8 @@
+ int
+ SSL_pending (SSL * ssl)
+ {
++ if (ssl->ssl_peek_avail)
++ return ssl->ssl_peek_avail;
+ return gnutls_record_check_pending (ssl->gnutls_state);
+ }
+
+@@ -480,11 +499,50 @@
+ return 1;
+ }
+
++int SSL_peek(SSL *ssl, void *buf, int len)
++{
++ if (len > ssl->ssl_peek_buffer_size) {
++ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
++ ssl->ssl_peek_buffer_size = len;
++ }
++
++ if (ssl->ssl_peek_avail == 0) {
++
++ int ret;
++
++ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
++ ssl->last_error = ret;
++
++ if (ret > 0)
++ ssl->ssl_peek_avail += ret;
++ }
++
++ if (len > ssl->ssl_peek_avail)
++ len = ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, len);
++
++ return len;
++}
++
+ int
+ SSL_read (SSL * ssl, void *buf, int len)
+ {
+ int ret;
+
++ if (ssl->ssl_peek_avail) {
++ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, n);
++
++ if (ssl->ssl_peek_avail > n)
++ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
++
++ ssl->ssl_peek_avail -= n;
++
++ return n;
++ }
++
+ ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
+ ssl->last_error = ret;
+
+Index: gnutls-1.6.0/includes/gnutls/openssl.h
+===================================================================
+--- gnutls-1.6.0.orig/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100
++++ gnutls-1.6.0/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100
+@@ -164,6 +164,11 @@
+
+ gnutls_transport_ptr_t rfd;
+ gnutls_transport_ptr_t wfd;
++
++ char *ssl_peek_buffer;
++ size_t ssl_peek_buffer_size;
++ size_t ssl_peek_avail;
++
+ };
+
+ #define rbio gnutls_state
diff --git a/recipes/gnutls/gnutls-2.4.2/gnutls-replace-siginterrupt.patch b/recipes/gnutls/gnutls-2.4.2/gnutls-replace-siginterrupt.patch
new file mode 100644
index 0000000000..9b734a9bf9
--- /dev/null
+++ b/recipes/gnutls/gnutls-2.4.2/gnutls-replace-siginterrupt.patch
@@ -0,0 +1,37 @@
+Index: gnutls-2.4.2/src/tests.c
+===================================================================
+--- gnutls-2.4.2.orig/src/tests.c 2008-09-15 13:04:19.000000000 -0700
++++ gnutls-2.4.2/src/tests.c 2009-03-04 15:25:09.000000000 -0800
+@@ -491,6 +491,7 @@
+ int old, secs = 6;
+
+ #ifndef _WIN32
++ struct sigaction act;
+ signal (SIGALRM, got_alarm);
+ #endif
+
+@@ -511,7 +512,9 @@
+ return TEST_FAILED;
+
+ #ifndef _WIN32
+- old = siginterrupt (SIGALRM, 1);
++ (void) sigaction(SIGALRM, NULL, &act);
++ act.sa_flags &= ~SA_RESTART;
++ old = sigaction(SIGALRM, &act, NULL);
+ alarm (secs);
+ #else
+ setsockopt ((int)gnutls_transport_get_ptr (session), SOL_SOCKET, SO_RCVTIMEO,
+@@ -525,7 +528,12 @@
+ while (ret > 0);
+
+ #ifndef _WIN32
+- siginterrupt (SIGALRM, old);
++ (void) sigaction(SIGALRM, NULL, &act);
++ if (old)
++ act.sa_flags &= ~SA_RESTART;
++ else
++ act.sa_flags |= SA_RESTART;
++ sigaction(SIGALRM, &act, NULL);
+ #else
+ if (WSAGetLastError () == WSAETIMEDOUT ||
+ WSAGetLastError () == WSAECONNABORTED)
diff --git a/recipes/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch b/recipes/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch
new file mode 100644
index 0000000000..e2a2762424
--- /dev/null
+++ b/recipes/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch
@@ -0,0 +1,16 @@
+The version of texinfo in Debian Sarge does not understand the @euro{} command.
+This patch replaces the @euro{} command with the word "euro".
+
+--- gnutls-1.3.5/doc/signatures.texi.orig 2006-04-26 08:06:40.918268000 +0930
++++ gnutls-1.3.5/doc/signatures.texi 2006-04-26 08:06:52.446515440 +0930
+@@ -11,8 +11,8 @@
+ long as it is difficult enough to generate two different messages with
+ the same hash algorithm output. In that case the same signature could
+ be used as a proof for both messages. Nobody wants to sign an innocent
+-message of donating 1 @euro{} to Greenpeace and find out that he
+-donated 1.000.000 @euro{} to Bad Inc.
++message of donating 1 euro to Greenpeace and find out that he
++donated 1.000.000 euro to Bad Inc.
+
+ For a hash algorithm to be called cryptographic the following three
+ requirements must hold
diff --git a/recipes/gnutls/gnutls.inc b/recipes/gnutls/gnutls.inc
new file mode 100644
index 0000000000..e438423c9c
--- /dev/null
+++ b/recipes/gnutls/gnutls.inc
@@ -0,0 +1,36 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+HOMEPAGE = "http://www.gnu.org/software/gnutls/"
+DEPENDS = "zlib libgcrypt lzo"
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--with-included-opencdk --with-included-libtasn1"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+
+ install -d ${STAGING_DATADIR}/aclocal
+ cp ${S}/lib/libgnutls.m4 ${STAGING_DATADIR}/aclocal/
+ cp ${S}/libextra/libgnutls-extra.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin ${PN}-xx"
+
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv \
+ ${bindir}/gnutls-cli \
+ ${bindir}/srptool \
+ ${bindir}/psktool \
+ ${bindir}/certtool \
+ ${bindir}/gnutls-srpcrypt"
+
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
diff --git a/recipes/gnutls/gnutls_1.4.5.bb b/recipes/gnutls/gnutls_1.4.5.bb
new file mode 100644
index 0000000000..a5e58735a0
--- /dev/null
+++ b/recipes/gnutls/gnutls_1.4.5.bb
@@ -0,0 +1,8 @@
+require gnutls.inc
+
+# fix wrong dependency
+do_configure_prepend() {
+ sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
+}
+
+PR = "r3"
diff --git a/recipes/gnutls/gnutls_1.6.3.bb b/recipes/gnutls/gnutls_1.6.3.bb
new file mode 100644
index 0000000000..7a89835237
--- /dev/null
+++ b/recipes/gnutls/gnutls_1.6.3.bb
@@ -0,0 +1,14 @@
+require gnutls.inc
+
+SRC_URI += "\
+ file://gnutls-openssl.patch;patch=1 \
+ file://gnutls-texinfo-euro.patch;patch=1 \
+ file://configure_madness.patch;patch=1 \
+ "
+
+# fix wrong dependency
+do_configure_prepend() {
+ sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
+}
+
+PR = "r6"
diff --git a/recipes/gnutls/gnutls_2.4.2.bb b/recipes/gnutls/gnutls_2.4.2.bb
new file mode 100644
index 0000000000..d33e687741
--- /dev/null
+++ b/recipes/gnutls/gnutls_2.4.2.bb
@@ -0,0 +1,10 @@
+require gnutls.inc
+
+SRC_URI += "\
+ file://gnutls-openssl.patch;patch=1 \
+ file://gnutls-texinfo-euro.patch;patch=1 \
+ file://configure_madness.patch;patch=1 \
+ file://gnutls-replace-siginterrupt.patch;patch=1 \
+ "
+
+PR = "r4"
diff --git a/recipes/gnutls/libtasn1_1.7.bb b/recipes/gnutls/libtasn1_1.7.bb
new file mode 100644
index 0000000000..f9a4ae6e1c
--- /dev/null
+++ b/recipes/gnutls/libtasn1_1.7.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Library for ASN.1 and DER manipulation"
+LICENSE = "LGPL"
+
+PR = "r1"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/libtasn1/libtasn1-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+