aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gobject-introspection
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-17 16:15:38 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-17 16:17:32 -0700
commit8d906dfca260c2c1b0a40b558ad8d64dbfd028bc (patch)
tree0066ce4704206da630b6178f656786ceaa302a11 /recipes/gobject-introspection
parent4e5f9e10101d35729cf4aa25c55e7b7c45041a16 (diff)
downloadopenembedded-8d906dfca260c2c1b0a40b558ad8d64dbfd028bc.tar.gz
gobject-introspection: Use /usr/bin/env for python
Scripts that do #!@PERL@ or #!@PYTHON@ and replace that with a full path are in danger of breaking in certain environments (such as some autobuilders) and should instead use /usr/bin/env. While in here, use GNOME_MIRROR for the sources. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/gobject-introspection')
-rw-r--r--recipes/gobject-introspection/gobject-introspection/use-usr-bin-env-for-python.patch20
-rw-r--r--recipes/gobject-introspection/gobject-introspection_0.9.10.bb4
2 files changed, 23 insertions, 1 deletions
diff --git a/recipes/gobject-introspection/gobject-introspection/use-usr-bin-env-for-python.patch b/recipes/gobject-introspection/gobject-introspection/use-usr-bin-env-for-python.patch
new file mode 100644
index 0000000000..67b85470d3
--- /dev/null
+++ b/recipes/gobject-introspection/gobject-introspection/use-usr-bin-env-for-python.patch
@@ -0,0 +1,20 @@
+Index: gobject-introspection-0.9.10/tools/g-ir-annotation-tool.in
+===================================================================
+--- gobject-introspection-0.9.10.orig/tools/g-ir-annotation-tool.in
++++ gobject-introspection-0.9.10/tools/g-ir-annotation-tool.in
+@@ -1,4 +1,4 @@
+-#!@PYTHON@
++#!/usr/bin/env python
+ # -*- Mode: Python -*-
+ # GObject-Introspection - a framework for introspecting GObject libraries
+ # Copyright (C) 2008 Johan Dahlin
+Index: gobject-introspection-0.9.10/tools/g-ir-scanner.in
+===================================================================
+--- gobject-introspection-0.9.10.orig/tools/g-ir-scanner.in
++++ gobject-introspection-0.9.10/tools/g-ir-scanner.in
+@@ -1,4 +1,4 @@
+-#!@PYTHON@
++#!/usr/bin/env python
+ # -*- Mode: Python -*-
+ # GObject-Introspection - a framework for introspecting GObject libraries
+ # Copyright (C) 2008 Johan Dahlin
diff --git a/recipes/gobject-introspection/gobject-introspection_0.9.10.bb b/recipes/gobject-introspection/gobject-introspection_0.9.10.bb
index b982ce92fa..72836d56ca 100644
--- a/recipes/gobject-introspection/gobject-introspection_0.9.10.bb
+++ b/recipes/gobject-introspection/gobject-introspection_0.9.10.bb
@@ -4,12 +4,14 @@ DEPENDS = "glib-2.0 libffi"
BBCLASSEXTEND = "native"
DEPENDS_virtclass-native = "glib-2.0-native libffi-native"
LICENSE = "LGPL"
+PR = "r1"
SRC_URI[md5sum] = "e5cd63d6bcc5c105e898e7c33cf42175"
SRC_URI[sha256sum] = "4bf244db75df04499dea704e7734376c0fc5a3a17fb59be2123c8d76111e6fb8"
SRC_URI = "\
- http://ftp.acc.umu.se/pub/GNOME/sources/gobject-introspection/0.9/${BPN}-${PV}.tar.bz2 \
+ ${GNOME_MIRROR}/gobject-introspection/0.9/${BPN}-${PV}.tar.bz2 \
+ file://use-usr-bin-env-for-python.patch \
"
S = "${WORKDIR}/${BPN}-${PV}"