aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpdf
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpdf
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpdf')
-rw-r--r--recipes/gpdf/files/aclocal-lossage.patch11
-rw-r--r--recipes/gpdf/files/desktop.patch11
-rw-r--r--recipes/gpdf/files/gpdf-2.10.0-gcc4-2.patch30
-rw-r--r--recipes/gpdf/gpdf_2.10.0.bb16
-rw-r--r--recipes/gpdf/gpdf_2.7.90.bb13
-rw-r--r--recipes/gpdf/gpdf_2.8.0.bb17
-rw-r--r--recipes/gpdf/gpdf_2.8.2.bb16
7 files changed, 114 insertions, 0 deletions
diff --git a/recipes/gpdf/files/aclocal-lossage.patch b/recipes/gpdf/files/aclocal-lossage.patch
new file mode 100644
index 0000000000..cdbe8100bd
--- /dev/null
+++ b/recipes/gpdf/files/aclocal-lossage.patch
@@ -0,0 +1,11 @@
+--- gpdf-2.7.90/Makefile.am.old 2004-08-03 20:32:38.000000000 +0100
++++ gpdf-2.7.90/Makefile.am 2004-08-03 20:27:11.000000000 +0100
+@@ -43,7 +43,7 @@
+
+ DISTCHECK_CONFIGURE_FLAGS = --disable-schemas-install
+
+-ACLOCAL_AMFLAGS = -I $(datadir)/aclocal -I $(datadir)/aclocal/gnome2-macros
++# ACLOCAL_AMFLAGS = -I $(datadir)/aclocal -I $(datadir)/aclocal/gnome2-macros
+
+ CLEANFILES = \
+ $(schema_DATA) \
diff --git a/recipes/gpdf/files/desktop.patch b/recipes/gpdf/files/desktop.patch
new file mode 100644
index 0000000000..e76e63328a
--- /dev/null
+++ b/recipes/gpdf/files/desktop.patch
@@ -0,0 +1,11 @@
+--- gpdf-2.7.90/gpdf.desktop.in.old 2004-08-05 15:31:09.000000000 +0100
++++ gpdf-2.7.90/gpdf.desktop.in 2004-08-05 15:31:19.000000000 +0100
+@@ -3,7 +3,7 @@
+ _Name=PDF Viewer
+ _Comment=View PDF files
+ Exec=gpdf %U
+-Icon=gnome-pdf
++Icon=gnome-pdf.png
+ Terminal=false
+ Type=Application
+ Categories=GNOME;Application;Graphics;VectorGraphics;Viewer;
diff --git a/recipes/gpdf/files/gpdf-2.10.0-gcc4-2.patch b/recipes/gpdf/files/gpdf-2.10.0-gcc4-2.patch
new file mode 100644
index 0000000000..d45becb346
--- /dev/null
+++ b/recipes/gpdf/files/gpdf-2.10.0-gcc4-2.patch
@@ -0,0 +1,30 @@
+diff -Naur gpdf-2.10.0.orig/xpdf/TextOutputDev.h gpdf-2.10.0/xpdf/TextOutputDev.h
+--- gpdf-2.10.0.orig/xpdf/TextOutputDev.h 2005-08-23 21:59:57.000000000 +0000
++++ gpdf-2.10.0/xpdf/TextOutputDev.h 2005-08-23 22:00:10.000000000 +0000
+@@ -166,6 +166,8 @@
+ // TextLine
+ //------------------------------------------------------------------------
+
++class TextBlock;
++
+ class TextLine {
+ public:
+
+@@ -223,6 +225,8 @@
+ // TextBlock
+ //------------------------------------------------------------------------
+
++class TextPage;
++
+ class TextBlock {
+ public:
+
+@@ -342,6 +346,8 @@
+ // TextPage
+ //------------------------------------------------------------------------
+
++class TextLineFrag;
++
+ class TextPage {
+ public:
+
diff --git a/recipes/gpdf/gpdf_2.10.0.bb b/recipes/gpdf/gpdf_2.10.0.bb
new file mode 100644
index 0000000000..30c42dcb0c
--- /dev/null
+++ b/recipes/gpdf/gpdf_2.10.0.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+PR = "r0"
+
+inherit gnome
+
+SRC_URI_append = " file://gpdf-2.10.0-gcc4-2.patch;patch=1"
+
+DEPENDS = "gtk+ libgnomeui libbonoboui gnome-vfs gconf gettext libglade \
+ libgnomeprint libgnomeprintui gnome-common"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+do_configure_prepend () {
+ cp ${STAGING_DATADIR}/gnome-common/data/omf.make ${S}/help
+}
diff --git a/recipes/gpdf/gpdf_2.7.90.bb b/recipes/gpdf/gpdf_2.7.90.bb
new file mode 100644
index 0000000000..975523530a
--- /dev/null
+++ b/recipes/gpdf/gpdf_2.7.90.bb
@@ -0,0 +1,13 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+PR = "r2"
+
+inherit gnome gettext
+
+DEPENDS = "gtk+ libgnomeui libbonoboui gnome-vfs gconf gettext libglade \
+ libgnomeprint libgnomeprintui gnome-common"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+SRC_URI += "file://aclocal-lossage.patch;patch=1 \
+ file://desktop.patch;patch=1"
diff --git a/recipes/gpdf/gpdf_2.8.0.bb b/recipes/gpdf/gpdf_2.8.0.bb
new file mode 100644
index 0000000000..b4afdb02b8
--- /dev/null
+++ b/recipes/gpdf/gpdf_2.8.0.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+PR = "r0"
+
+inherit gnome
+
+DEPENDS = "gtk+ libgnomeui libbonoboui gnome-vfs gconf gettext libglade \
+ libgnomeprint libgnomeprintui gnome-common"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+SRC_URI += "file://aclocal-lossage.patch;patch=1 \
+ file://desktop.patch;patch=1"
+
+do_configure_prepend () {
+ cp ${STAGING_DATADIR}/gnome-common/data/omf.make ${S}/help
+}
diff --git a/recipes/gpdf/gpdf_2.8.2.bb b/recipes/gpdf/gpdf_2.8.2.bb
new file mode 100644
index 0000000000..3943ff93e1
--- /dev/null
+++ b/recipes/gpdf/gpdf_2.8.2.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+PR = "r0"
+
+inherit gnome
+
+DEPENDS = "gtk+ libgnomeui libbonoboui gnome-vfs gconf gettext libglade \
+ libgnomeprint libgnomeprintui gnome-common"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+SRC_URI += "file://aclocal-lossage.patch;patch=1"
+
+do_configure_prepend () {
+ cp ${STAGING_DATADIR}/gnome-common/data/omf.make ${S}/help
+}