aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-autostarter
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-05-01 22:35:04 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-05-01 22:35:04 +0200
commit9edaaef28d294861127374b780c31e302155d26b (patch)
tree3bdc3f410af8b18752cefae33d93b0f65b02342d /recipes/gpe-autostarter
parent44c9446696db8afd449eaf8139819cd69500dcc1 (diff)
downloadopenembedded-9edaaef28d294861127374b780c31e302155d26b.tar.gz
gpe-autostarter: Makefile fix - don't strip on install
Diffstat (limited to 'recipes/gpe-autostarter')
-rw-r--r--recipes/gpe-autostarter/files/makefile-fix.patch11
-rw-r--r--recipes/gpe-autostarter/gpe-autostarter_0.11.bb4
-rw-r--r--recipes/gpe-autostarter/gpe-autostarter_0.12.bb4
-rw-r--r--recipes/gpe-autostarter/gpe-autostarter_0.6.bb2
-rw-r--r--recipes/gpe-autostarter/gpe-autostarter_0.7.bb2
-rw-r--r--recipes/gpe-autostarter/gpe-autostarter_svn.bb2
6 files changed, 23 insertions, 2 deletions
diff --git a/recipes/gpe-autostarter/files/makefile-fix.patch b/recipes/gpe-autostarter/files/makefile-fix.patch
new file mode 100644
index 0000000000..97ee907604
--- /dev/null
+++ b/recipes/gpe-autostarter/files/makefile-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile.old 2006-08-23 15:08:36.000000000 +0200
++++ gpe-autostarter-0.12/Makefile 2009-05-01 22:32:50.000000000 +0200
+@@ -28,7 +28,7 @@
+
+ install-program: all
+ install -d $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/
+ install -d $(DESTDIR)/etc/X11/Xsession.d
+ install $(PACKAGE).xsession $(DESTDIR)/etc/X11/Xsession.d/50$(PACKAGE)
+
diff --git a/recipes/gpe-autostarter/gpe-autostarter_0.11.bb b/recipes/gpe-autostarter/gpe-autostarter_0.11.bb
index b228b3d7b2..26a9e97b08 100644
--- a/recipes/gpe-autostarter/gpe-autostarter_0.11.bb
+++ b/recipes/gpe-autostarter/gpe-autostarter_0.11.bb
@@ -5,4 +5,6 @@ LICENSE = "GPL"
inherit gpe
-SRC_URI += " file://dbus-new-api.patch;patch=1"
+SRC_URI += "file://dbus-new-api.patch;patch=1 \
+ file://makefile-fix.patch;patch=1"
+
diff --git a/recipes/gpe-autostarter/gpe-autostarter_0.12.bb b/recipes/gpe-autostarter/gpe-autostarter_0.12.bb
index c47f75797e..4c4293ee6c 100644
--- a/recipes/gpe-autostarter/gpe-autostarter_0.12.bb
+++ b/recipes/gpe-autostarter/gpe-autostarter_0.12.bb
@@ -5,4 +5,6 @@ RDEPENDS = "hotplug-dbus"
inherit gpe
-SRC_URI += "file://wireless.patch;patch=1"
+SRC_URI += "file://wireless.patch;patch=1 \
+ file://makefile-fix.patch;patch=1"
+
diff --git a/recipes/gpe-autostarter/gpe-autostarter_0.6.bb b/recipes/gpe-autostarter/gpe-autostarter_0.6.bb
index ef7f255db6..0ba68b7f21 100644
--- a/recipes/gpe-autostarter/gpe-autostarter_0.6.bb
+++ b/recipes/gpe-autostarter/gpe-autostarter_0.6.bb
@@ -4,3 +4,5 @@ DEPENDS = "glib-2.0 dbus-glib hotplug-dbus"
RDEPENDS = "hotplug-dbus"
inherit gpe
+
+SRC_URI += "file://makefile-fix.patch;patch=1"
diff --git a/recipes/gpe-autostarter/gpe-autostarter_0.7.bb b/recipes/gpe-autostarter/gpe-autostarter_0.7.bb
index f92b5df16b..9e92740d40 100644
--- a/recipes/gpe-autostarter/gpe-autostarter_0.7.bb
+++ b/recipes/gpe-autostarter/gpe-autostarter_0.7.bb
@@ -4,3 +4,5 @@ DEPENDS = "glib-2.0 dbus-glib hotplug-dbus virtual/libx11"
RDEPENDS = "hotplug-dbus"
inherit gpe
+
+SRC_URI += "file://makefile-fix.patch;patch=1"
diff --git a/recipes/gpe-autostarter/gpe-autostarter_svn.bb b/recipes/gpe-autostarter/gpe-autostarter_svn.bb
index 2742952e0f..8d275b5565 100644
--- a/recipes/gpe-autostarter/gpe-autostarter_svn.bb
+++ b/recipes/gpe-autostarter/gpe-autostarter_svn.bb
@@ -8,6 +8,8 @@ inherit gpe
SRC_URI = "${GPE_SVN} \
file://svn-build.patch;patch=1"
+SRC_URI += "file://makefile-fix.patch;patch=1"
+
S = "${WORKDIR}/${PN}"
export CVSBUILD="no"