aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-beam
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-beam
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-beam')
-rw-r--r--recipes/gpe-beam/gpe-beam-0.2.6/vcard-send.patch33
-rw-r--r--recipes/gpe-beam/gpe-beam-0.2.7/decl.patch12
-rw-r--r--recipes/gpe-beam/gpe-beam-0.2.8/dbus-new-api.patch76
-rw-r--r--recipes/gpe-beam/gpe-beam.inc5
-rw-r--r--recipes/gpe-beam/gpe-beam_0.2.3.bb5
-rw-r--r--recipes/gpe-beam/gpe-beam_0.2.6.bb8
-rw-r--r--recipes/gpe-beam/gpe-beam_0.2.7.bb8
-rw-r--r--recipes/gpe-beam/gpe-beam_0.2.8.bb7
-rw-r--r--recipes/gpe-beam/gpe-beam_0.2.9.bb6
9 files changed, 160 insertions, 0 deletions
diff --git a/recipes/gpe-beam/gpe-beam-0.2.6/vcard-send.patch b/recipes/gpe-beam/gpe-beam-0.2.6/vcard-send.patch
new file mode 100644
index 0000000000..1a2c66f821
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam-0.2.6/vcard-send.patch
@@ -0,0 +1,33 @@
+Index: main.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-beam/main.c,v
+retrieving revision 1.26
+diff -u -r1.26 main.c
+--- main.c 16 Oct 2004 12:17:51 -0000 1.26
++++ main.c 17 Oct 2004 12:43:16 -0000
+@@ -632,7 +632,7 @@
+
+
+ static void
+-send_vcard (void)
++do_send_vcard (void)
+ {
+ if (!radio_is_on)
+ radio_on ();
+@@ -651,6 +651,16 @@
+ }
+ }
+
++static void
++send_vcard (void)
++{
++ scan_thread =
++ g_thread_create ((GThreadFunc)
++ do_send_vcard, NULL, FALSE, NULL);
++ if (scan_thread == NULL)
++ gpe_perror_box (_("Unable to start sender."));
++}
++
+
+ static gboolean
+ get_irstatus (void)
diff --git a/recipes/gpe-beam/gpe-beam-0.2.7/decl.patch b/recipes/gpe-beam/gpe-beam-0.2.7/decl.patch
new file mode 100644
index 0000000000..0d0e889b42
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam-0.2.7/decl.patch
@@ -0,0 +1,12 @@
+diff -u -r1.6 main.h
+--- main.h 16 Oct 2004 12:17:51 -0000 1.6
++++ main.h 29 Jul 2005 21:17:02 -0000
+@@ -21,8 +21,6 @@
+ #define HINT_HTTP 0x10
+ #define HINT_OBEX 0x20
+
+-extern gboolean radio_is_on;
+-
+ extern GdkWindow *dock_window;
+ extern void schedule_message_delete (guint id, guint time);
+ extern void send_data (char *filename, char *data, size_t len);
diff --git a/recipes/gpe-beam/gpe-beam-0.2.8/dbus-new-api.patch b/recipes/gpe-beam/gpe-beam-0.2.8/dbus-new-api.patch
new file mode 100644
index 0000000000..723ba64194
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam-0.2.8/dbus-new-api.patch
@@ -0,0 +1,76 @@
+--- gpe-beam-0.2.7/dbus.c.orig 2005-08-29 21:05:28 +0200
++++ gpe-beam-0.2.7/dbus.c 2005-08-29 21:07:11 +0200
+@@ -40,7 +40,11 @@
+ return obex_client_handle_dbus_request (connection, message);
+
+ if (dbus_message_is_signal (message,
++#ifndef DBUS_INTERFACE_LOCAL
+ DBUS_INTERFACE_ORG_FREEDESKTOP_LOCAL,
++#else
++ DBUS_INTERFACE_LOCAL,
++#endif
+ "Disconnected"))
+ exit (0);
+
+@@ -70,10 +70,18 @@
+
+ dbus_connection_register_object_path (connection, object_path, &dbus_obex_vtable, NULL);
+
++#ifndef DBUS_INTERFACE_LOCAL
+ dbus_bus_acquire_service (connection, SERVICE_NAME, 0, &error);
++#else
++ dbus_bus_request_name (connection, SERVICE_NAME, 0, &error);
++#endif
+ if (dbus_error_is_set (&error))
+ {
++#ifndef DBUS_INTERFACE_LOCAL
+ gpe_error_box_fmt (_("Failed to acquire service: %s"), error.message);
++#else
++ gpe_error_box_fmt (_("Failed to request name: %s"), error.message);
++#endif
+ dbus_error_free (&error);
+ }
+ }
+--- gpe-beam-0.2.7/obexclient-dbus.c.orig 2005-08-29 21:05:33 +0200
++++ gpe-beam-0.2.7/obexclient-dbus.c 2005-08-29 21:10:00 +0200
+@@ -73,7 +73,11 @@
+ if (dbus_message_iter_get_arg_type (&iter) != DBUS_TYPE_STRING)
+ goto wrong_args;
+
++#ifndef DBUS_INTERFACE_LOCAL
+ filename = dbus_message_iter_get_string (&iter);
++#else
++ dbus_message_iter_get_basic (&iter, &filename);
++#endif
+
+ if (!dbus_message_iter_next (&iter))
+ goto wrong_args;
+@@ -81,16 +81,28 @@
+ if (dbus_message_iter_get_arg_type (&iter) != DBUS_TYPE_STRING)
+ goto wrong_args;
+
++#ifndef DBUS_INTERFACE_LOCAL
+ mime_type = dbus_message_iter_get_string (&iter);
++#else
++ dbus_message_iter_get_basic (&iter, &mime_type);
++#endif
+
+ if (!dbus_message_iter_next (&iter))
+ goto wrong_args;
+
+ if (dbus_message_iter_get_arg_type (&iter) != DBUS_TYPE_ARRAY
++#ifndef DBUS_INTERFACE_LOCAL
+ || dbus_message_iter_get_array_type (&iter) != DBUS_TYPE_BYTE)
++#else
++ || dbus_message_iter_get_element_type (&iter) != DBUS_TYPE_BYTE)
++#endif
+ goto wrong_args;
+
++#ifndef DBUS_INTERFACE_LOCAL
+ dbus_message_iter_get_byte_array (&iter, &data, &len);
++#else
++ dbus_message_iter_get_fixed_array (&iter, &data, &len);
++#endif
+
+ reply = dbus_message_new_method_return (message);
+ if (!reply)
diff --git a/recipes/gpe-beam/gpe-beam.inc b/recipes/gpe-beam/gpe-beam.inc
new file mode 100644
index 0000000000..5ca6df0b03
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam.inc
@@ -0,0 +1,5 @@
+DESCRIPTION = "GPE infrared communication applet"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libgpewidget libmimedir libgpevtype openobex irda-utils dbus-glib"
diff --git a/recipes/gpe-beam/gpe-beam_0.2.3.bb b/recipes/gpe-beam/gpe-beam_0.2.3.bb
new file mode 100644
index 0000000000..e5861f069a
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam_0.2.3.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+RDEPENDS = "libopenobex-1.0-1"
+
+inherit gpe pkgconfig
diff --git a/recipes/gpe-beam/gpe-beam_0.2.6.bb b/recipes/gpe-beam/gpe-beam_0.2.6.bb
new file mode 100644
index 0000000000..89f8e8230a
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam_0.2.6.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+RDEPENDS = "libopenobex-1.0-1 irda-utils"
+PR = "r1"
+
+SRC_URI += "file://vcard-send.patch;patch=1;pnum=0"
+
+inherit gpe
diff --git a/recipes/gpe-beam/gpe-beam_0.2.7.bb b/recipes/gpe-beam/gpe-beam_0.2.7.bb
new file mode 100644
index 0000000000..f19b64d933
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam_0.2.7.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+RDEPENDS = "libopenobex-1.0-1 irda-utils"
+PR = "r1"
+
+SRC_URI += "file://decl.patch;patch=1;pnum=0"
+
+inherit gpe
diff --git a/recipes/gpe-beam/gpe-beam_0.2.8.bb b/recipes/gpe-beam/gpe-beam_0.2.8.bb
new file mode 100644
index 0000000000..9795827aa8
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam_0.2.8.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+RDEPENDS = "irda-utils"
+
+SRC_URI += "file://dbus-new-api.patch;patch=1"
+
+inherit gpe
diff --git a/recipes/gpe-beam/gpe-beam_0.2.9.bb b/recipes/gpe-beam/gpe-beam_0.2.9.bb
new file mode 100644
index 0000000000..b96bed4a2f
--- /dev/null
+++ b/recipes/gpe-beam/gpe-beam_0.2.9.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+RDEPENDS = "irda-utils"
+
+inherit gpe
+