aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-bluetooth
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-bluetooth
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-bluetooth')
-rw-r--r--recipes/gpe-bluetooth/files/bluez-pin-gpe.glade182
-rw-r--r--recipes/gpe-bluetooth/files/hciattach-bts.patch16
-rw-r--r--recipes/gpe-bluetooth/files/include-sdp_lib.patch9
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth.inc11
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth_0.49.bb3
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth_0.51.bb7
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth_0.52.bb1
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth_0.53.bb1
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth_0.54.bb6
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth_0.55.bb4
-rw-r--r--recipes/gpe-bluetooth/gpe-bluetooth_svn.bb10
11 files changed, 250 insertions, 0 deletions
diff --git a/recipes/gpe-bluetooth/files/bluez-pin-gpe.glade b/recipes/gpe-bluetooth/files/bluez-pin-gpe.glade
new file mode 100644
index 0000000000..379ec5499a
--- /dev/null
+++ b/recipes/gpe-bluetooth/files/bluez-pin-gpe.glade
@@ -0,0 +1,182 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
+
+<glade-interface>
+<requires lib="gnome"/>
+
+<widget class="GtkDialog" id="dialog1">
+ <property name="visible">True</property>
+ <property name="title" translatable="yes">Bluetooth PIN</property>
+ <property name="type">GTK_WINDOW_TOPLEVEL</property>
+ <property name="window_position">GTK_WIN_POS_NONE</property>
+ <property name="modal">False</property>
+ <property name="resizable">True</property>
+ <property name="destroy_with_parent">False</property>
+ <property name="has_separator">False</property>
+
+ <child internal-child="vbox">
+ <widget class="GtkVBox" id="dialog-vbox1">
+ <property name="visible">True</property>
+ <property name="homogeneous">False</property>
+ <property name="spacing">0</property>
+
+ <child internal-child="action_area">
+ <widget class="GtkHButtonBox" id="dialog-action_area1">
+ <property name="visible">True</property>
+ <property name="layout_style">GTK_BUTTONBOX_END</property>
+
+ <child>
+ <widget class="GtkButton" id="cancelbutton1">
+ <property name="visible">True</property>
+ <property name="can_default">True</property>
+ <property name="can_focus">True</property>
+ <property name="label">gtk-cancel</property>
+ <property name="use_stock">True</property>
+ <property name="relief">GTK_RELIEF_NORMAL</property>
+ <property name="response_id">-6</property>
+ </widget>
+ </child>
+
+ <child>
+ <widget class="GtkButton" id="okbutton1">
+ <property name="visible">True</property>
+ <property name="can_default">True</property>
+ <property name="can_focus">True</property>
+ <property name="label">gtk-ok</property>
+ <property name="use_stock">True</property>
+ <property name="relief">GTK_RELIEF_NORMAL</property>
+ <property name="response_id">-5</property>
+ </widget>
+ </child>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">False</property>
+ <property name="fill">True</property>
+ <property name="pack_type">GTK_PACK_END</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkHBox" id="hbox1">
+ <property name="visible">True</property>
+ <property name="homogeneous">False</property>
+ <property name="spacing">0</property>
+
+ <child>
+ <widget class="GtkImage" id="image1">
+ <property name="visible">True</property>
+ <property name="xalign">0.5</property>
+ <property name="yalign">0.5</property>
+ <property name="xpad">8</property>
+ <property name="ypad">8</property>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkVBox" id="vbox1">
+ <property name="visible">True</property>
+ <property name="homogeneous">False</property>
+ <property name="spacing">0</property>
+
+ <child>
+ <widget class="GtkLabel" id="label1">
+ <property name="visible">True</property>
+ <property name="label" translatable="yes">Connection type</property>
+ <property name="use_underline">False</property>
+ <property name="use_markup">False</property>
+ <property name="justify">GTK_JUSTIFY_LEFT</property>
+ <property name="wrap">True</property>
+ <property name="selectable">False</property>
+ <property name="xalign">0.5</property>
+ <property name="yalign">0.5</property>
+ <property name="xpad">0</property>
+ <property name="ypad">0</property>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkHBox" id="hbox2">
+ <property name="visible">True</property>
+ <property name="homogeneous">False</property>
+ <property name="spacing">4</property>
+
+ <child>
+ <widget class="GtkLabel" id="label2">
+ <property name="visible">True</property>
+ <property name="label" translatable="yes">_PIN:</property>
+ <property name="use_underline">True</property>
+ <property name="use_markup">False</property>
+ <property name="justify">GTK_JUSTIFY_LEFT</property>
+ <property name="wrap">False</property>
+ <property name="selectable">False</property>
+ <property name="xalign">0.5</property>
+ <property name="yalign">0.5</property>
+ <property name="xpad">0</property>
+ <property name="ypad">0</property>
+ <property name="mnemonic_widget">entry1</property>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkEntry" id="entry1">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="editable">True</property>
+ <property name="visibility">True</property>
+ <property name="max_length">0</property>
+ <property name="text" translatable="yes"></property>
+ <property name="has_frame">True</property>
+ <property name="invisible_char" translatable="yes">*</property>
+ <property name="activates_default">False</property>
+ <accessibility>
+ <atkrelation target="entry1" type="label-for"/>
+ </accessibility>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+ </widget>
+ </child>
+</widget>
+
+</glade-interface>
diff --git a/recipes/gpe-bluetooth/files/hciattach-bts.patch b/recipes/gpe-bluetooth/files/hciattach-bts.patch
new file mode 100644
index 0000000000..aeff8b02b1
--- /dev/null
+++ b/recipes/gpe-bluetooth/files/hciattach-bts.patch
@@ -0,0 +1,16 @@
+--- gpe-bluetooth-0.54/hciattach.sh.orig 2006-08-20 15:04:05.341384325 +0200
++++ gpe-bluetooth-0.54/hciattach.sh 2006-08-20 15:05:04.629179674 +0200
+@@ -2,8 +2,12 @@
+
+ if [ -f /etc/sysconfig/bluetooth ]; then
+ . /etc/sysconfig/bluetooth
++ if [ -f "$BLUETOOTH_SCRIPT" ]; then
++ BTS="-S $BLUETOOTH_SCRIPT"
++ fi
++
++ exec /sbin/hciattach -n $BLUETOOTH_PORT $BLUETOOTH_PROTOCOL $BLUETOOTH_SPEED $BTS
+
+- exec /sbin/hciattach -n $BLUETOOTH_PORT $BLUETOOTH_PROTOCOL $BLUETOOTH_SPEED
+ else
+ echo "Bluetooth not configured"
+ exit 1
diff --git a/recipes/gpe-bluetooth/files/include-sdp_lib.patch b/recipes/gpe-bluetooth/files/include-sdp_lib.patch
new file mode 100644
index 0000000000..8ec1ab3af3
--- /dev/null
+++ b/recipes/gpe-bluetooth/files/include-sdp_lib.patch
@@ -0,0 +1,9 @@
+--- gpe-bluetooth-0.54/main.h.orig 2006-08-31 09:49:46.000000000 +0200
++++ gpe-bluetooth-0.54/main.h 2006-08-31 09:49:48.000000000 +0200
+@@ -1,5 +1,6 @@
+ #include <gtk/gtk.h>
+ #include <bluetooth/sdp.h>
++#include <bluetooth/sdp_lib.h>
+
+ struct bt_device
+ {
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth.inc b/recipes/gpe-bluetooth/gpe-bluetooth.inc
new file mode 100644
index 0000000000..c258832c8b
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "GPE bluetooth support user interface tool."
+SECTION = "gpe"
+LICENSE = "GPL"
+PRIORITY = "optional"
+DEPENDS = "gtk+ libcontactsdb libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus-glib libglade blueprobe bluez-utils-dbus"
+RDEPENDS = "bluez-utils-dbus blueprobe"
+
+GPE_TARBALL_SUFFIX= "bz2"
+inherit gpe autotools
+
+FILES_${PN} += '${datadir}/bluez-pin'
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth_0.49.bb b/recipes/gpe-bluetooth/gpe-bluetooth_0.49.bb
new file mode 100644
index 0000000000..396beeb014
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth_0.49.bb
@@ -0,0 +1,3 @@
+require gpe-bluetooth.inc
+
+DEPENDS = "gtk+ libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus-glib libglade blueprobe bluez-utils-dbus libcontactsdb"
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth_0.51.bb b/recipes/gpe-bluetooth/gpe-bluetooth_0.51.bb
new file mode 100644
index 0000000000..98cdbc4b7f
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth_0.51.bb
@@ -0,0 +1,7 @@
+require gpe-bluetooth.inc
+
+PR = "r1"
+
+do_configure () {
+ autotools_do_configure
+}
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth_0.52.bb b/recipes/gpe-bluetooth/gpe-bluetooth_0.52.bb
new file mode 100644
index 0000000000..66bc3f0b24
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth_0.52.bb
@@ -0,0 +1 @@
+require gpe-bluetooth.inc
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth_0.53.bb b/recipes/gpe-bluetooth/gpe-bluetooth_0.53.bb
new file mode 100644
index 0000000000..66bc3f0b24
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth_0.53.bb
@@ -0,0 +1 @@
+require gpe-bluetooth.inc
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth_0.54.bb b/recipes/gpe-bluetooth/gpe-bluetooth_0.54.bb
new file mode 100644
index 0000000000..9164cc4088
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth_0.54.bb
@@ -0,0 +1,6 @@
+require gpe-bluetooth.inc
+
+PR = "r1"
+
+SRC_URI += "file://hciattach-bts.patch;patch=1 \
+ file://include-sdp_lib.patch;patch=1"
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth_0.55.bb b/recipes/gpe-bluetooth/gpe-bluetooth_0.55.bb
new file mode 100644
index 0000000000..e6ff0d6624
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth_0.55.bb
@@ -0,0 +1,4 @@
+require gpe-bluetooth.inc
+
+PR = "r0"
+
diff --git a/recipes/gpe-bluetooth/gpe-bluetooth_svn.bb b/recipes/gpe-bluetooth/gpe-bluetooth_svn.bb
new file mode 100644
index 0000000000..956e82e0ad
--- /dev/null
+++ b/recipes/gpe-bluetooth/gpe-bluetooth_svn.bb
@@ -0,0 +1,10 @@
+require gpe-bluetooth.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.54+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "${GPE_SVN}"
+
+S = ${WORKDIR}/${PN}