summaryrefslogtreecommitdiffstats
path: root/recipes/gpe-contacts
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-contacts
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-contacts')
-rw-r--r--recipes/gpe-contacts/files/handle-import-categories.patch39
-rw-r--r--recipes/gpe-contacts/gpe-contacts.inc14
-rw-r--r--recipes/gpe-contacts/gpe-contacts_0.45.bb14
-rw-r--r--recipes/gpe-contacts/gpe-contacts_0.46.bb13
-rw-r--r--recipes/gpe-contacts/gpe-contacts_0.47.bb13
-rw-r--r--recipes/gpe-contacts/gpe-contacts_0.49.bb13
-rw-r--r--recipes/gpe-contacts/gpe-contacts_svn.bb20
7 files changed, 126 insertions, 0 deletions
diff --git a/recipes/gpe-contacts/files/handle-import-categories.patch b/recipes/gpe-contacts/files/handle-import-categories.patch
new file mode 100644
index 0000000000..f64b1f6bbf
--- /dev/null
+++ b/recipes/gpe-contacts/files/handle-import-categories.patch
@@ -0,0 +1,39 @@
+diff -r abc014466432 import-vcard.c
+--- a/import-vcard.c Mon Jan 21 01:55:53 2008 +0200
++++ b/import-vcard.c Mon Jan 21 02:31:28 2008 +0200
+@@ -77,6 +77,35 @@ do_import_vcard (MIMEDirVCard *card)
+ {
+ gpe_tag_pair *t = i->data;
+
++ if (!strcasecmp(t->tag, "CATEGORY"))
++ {
++ char *p, *e;
++ int cat_id;
++
++ for (p = t->value; p; p = e)
++ {
++ while (*p == ' ')
++ p++;
++ e = strchr(p, ',');
++ if (e)
++ *e++ = 0;
++ cat_id = gpe_pim_category_id(p);
++ if (!cat_id)
++ {
++ if (!gpe_pim_category_new (p, &cat_id))
++ {
++ gpe_error_box ("Unable to create category for imported item");
++ sqlite_close (db);
++ return -2;
++ }
++ }
++ sqlite_exec_printf (db, "insert into contacts values ('%d', 'CATEGORY', '%d')", NULL, NULL, NULL,
++ id, cat_id);
++ }
++
++ }
++
++
+ sqlite_exec_printf (db, "insert into contacts values ('%d', '%q', '%q')", NULL, NULL, NULL,
+ id, t->tag, t->value);
+
diff --git a/recipes/gpe-contacts/gpe-contacts.inc b/recipes/gpe-contacts/gpe-contacts.inc
new file mode 100644
index 0000000000..e6af955190
--- /dev/null
+++ b/recipes/gpe-contacts/gpe-contacts.inc
@@ -0,0 +1,14 @@
+LICENSE = "GPL"
+inherit gpe autotools pkgconfig
+
+PR = "r0"
+
+DEPENDS = "libgpewidget libdisplaymigration libgpevtype dbus"
+SECTION = "gpe"
+RDEPENDS = "gpe-icons"
+DESCRIPTION = "GPE contacts manager"
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2"
+
+
+FILES_${PN} += " ${datadir}/gpe ${datadir}/gpe-contacts"
+
diff --git a/recipes/gpe-contacts/gpe-contacts_0.45.bb b/recipes/gpe-contacts/gpe-contacts_0.45.bb
new file mode 100644
index 0000000000..56c3af8eb2
--- /dev/null
+++ b/recipes/gpe-contacts/gpe-contacts_0.45.bb
@@ -0,0 +1,14 @@
+LICENSE = "GPL"
+inherit gpe autotools
+
+PR = "r0"
+
+DEPENDS = "libcontactsdb libgpewidget libgpepimc libdisplaymigration libgpevtype dbus-glib"
+SECTION = "gpe"
+RDEPENDS = "gpe-icons"
+DESCRIPTION = "GPE contacts manager"
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2"
+
+
+FILES_${PN} += " ${datadir}/gpe ${datadir}/gpe-contacts"
+
diff --git a/recipes/gpe-contacts/gpe-contacts_0.46.bb b/recipes/gpe-contacts/gpe-contacts_0.46.bb
new file mode 100644
index 0000000000..dadb085f06
--- /dev/null
+++ b/recipes/gpe-contacts/gpe-contacts_0.46.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "GPE contacts manager"
+LICENSE = "GPL"
+SECTION = "gpe"
+
+DEPENDS = "libcontactsdb libgpewidget libgpepimc libdisplaymigration libgpevtype dbus-glib"
+RDEPENDS = "gpe-icons"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
+
+FILES_${PN} += " ${datadir}/gpe ${datadir}/gpe-contacts"
+
diff --git a/recipes/gpe-contacts/gpe-contacts_0.47.bb b/recipes/gpe-contacts/gpe-contacts_0.47.bb
new file mode 100644
index 0000000000..dadb085f06
--- /dev/null
+++ b/recipes/gpe-contacts/gpe-contacts_0.47.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "GPE contacts manager"
+LICENSE = "GPL"
+SECTION = "gpe"
+
+DEPENDS = "libcontactsdb libgpewidget libgpepimc libdisplaymigration libgpevtype dbus-glib"
+RDEPENDS = "gpe-icons"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
+
+FILES_${PN} += " ${datadir}/gpe ${datadir}/gpe-contacts"
+
diff --git a/recipes/gpe-contacts/gpe-contacts_0.49.bb b/recipes/gpe-contacts/gpe-contacts_0.49.bb
new file mode 100644
index 0000000000..dadb085f06
--- /dev/null
+++ b/recipes/gpe-contacts/gpe-contacts_0.49.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "GPE contacts manager"
+LICENSE = "GPL"
+SECTION = "gpe"
+
+DEPENDS = "libcontactsdb libgpewidget libgpepimc libdisplaymigration libgpevtype dbus-glib"
+RDEPENDS = "gpe-icons"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
+
+FILES_${PN} += " ${datadir}/gpe ${datadir}/gpe-contacts"
+
diff --git a/recipes/gpe-contacts/gpe-contacts_svn.bb b/recipes/gpe-contacts/gpe-contacts_svn.bb
new file mode 100644
index 0000000000..9a626572a5
--- /dev/null
+++ b/recipes/gpe-contacts/gpe-contacts_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GPE contacts manager"
+SECTION = "gpe"
+LICENSE = "GPL"
+DEPENDS = "libcontactsdb libgpewidget libgpepimc libdisplaymigration libgpevtype dbus"
+RDEPENDS = "gpe-icons"
+PV = "0.47+svnr${SRCREV}"
+PR = "r2"
+
+inherit autotools gpe
+
+SRC_URI = "${GPE_SVN}"
+SRC_URI += "file://handle-import-categories.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+
+FILES_${PN} += " ${datadir}/gpe ${datadir}/gpe-contacts"
+
+DEFAULT_PREFERENCE = "-1"
+