aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-icons
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-15 20:06:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-21 20:28:50 -0700
commitcaa6067f7faf33200681c75843ce2e059cb1c0b4 (patch)
tree334e6f6ab9b6dea945d192cb73afda3b30dd218f /recipes/gpe-icons
parente84f4995e257e0505fb73432cbd2a9f53cdf074b (diff)
downloadopenembedded-caa6067f7faf33200681c75843ce2e059cb1c0b4.tar.gz
Various fixes for cp argument portability
Diffstat (limited to 'recipes/gpe-icons')
-rw-r--r--recipes/gpe-icons/gpe-icons.inc16
-rw-r--r--recipes/gpe-icons/gpe-theme-neo_git.bb2
2 files changed, 9 insertions, 9 deletions
diff --git a/recipes/gpe-icons/gpe-icons.inc b/recipes/gpe-icons/gpe-icons.inc
index 69c4ff21a2..f1ce472e89 100644
--- a/recipes/gpe-icons/gpe-icons.inc
+++ b/recipes/gpe-icons/gpe-icons.inc
@@ -13,9 +13,9 @@ ALTERNATIVE_PRIORITY ?= 1
# copy icons from other alternatives if they are not provided by current alternative
# ie gpe-sketchbook install own icon to pixmaps dir even before gpe-icons_*.bb is installed
-# so if we switch pixmaps link to neo theme, there would be no icon for gpe-sketchbook
+# so if we switch pixmaps link to neo theme, there would be no icon for gpe-sketchbook
# unless we copy it to neo theme in postinst too
-# inherit update-alternatives is not used, because not all distributions want to use it
+# inherit update-alternatives is not used, because not all distributions want to use it
# and conditional inherit is a bit difficult to use (inherit ${GPE_INHERIT} works, but only if we always want at least 1 bbclass)
pkg_postinst_shr() {
@@ -33,12 +33,12 @@ pkg_postinst_shr() {
if [ "${pixmap_dir}"x == "pixmaps.${PN}"x ] ; then
continue;
fi
- for pixmap in `find ${pixmap_dir}`; do
- pixmap_target=`echo ${pixmap} | sed "s/${pixmap_dir}/pixmaps.${PN}/g"`;
- if [ ! -e ${pixmap_target} ] ; then
- cp -ra ${pixmap} ${pixmap_target};
- echo "${pixmap} merged";
- fi;
+ for pixmap in `find ${pixmap_dir}`; do
+ pixmap_target=`echo ${pixmap} | sed "s/${pixmap_dir}/pixmaps.${PN}/g"`;
+ if [ ! -e ${pixmap_target} ] ; then
+ cp -Ra ${pixmap} ${pixmap_target};
+ echo "${pixmap} merged";
+ fi;
done
done
update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
diff --git a/recipes/gpe-icons/gpe-theme-neo_git.bb b/recipes/gpe-icons/gpe-theme-neo_git.bb
index 2e15976c25..8242a85599 100644
--- a/recipes/gpe-icons/gpe-theme-neo_git.bb
+++ b/recipes/gpe-icons/gpe-theme-neo_git.bb
@@ -20,7 +20,7 @@ ALTERNATIVE_PRIORITY = 10
do_install() {
install -d ${D}${datadir}/gpe/
install -d ${D}${datadir}/gpe/pixmaps.${PN}/
- cp -r ${S}/* "${D}${datadir}/gpe/pixmaps.${PN}/"
+ cp -R ${S}/* "${D}${datadir}/gpe/pixmaps.${PN}/"
}
FILES_${PN} = "${datadir}/gpe/pixmaps.${PN}/"