aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-nmf/gpe-nmf-0.22
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-nmf/gpe-nmf-0.22
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-nmf/gpe-nmf-0.22')
-rw-r--r--recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch15
-rw-r--r--recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch27
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch b/recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch
new file mode 100644
index 0000000000..cf6bd12da7
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- gpe-nmf-0.22/Makefile~fix-includepath
++++ gpe-nmf-0.22/Makefile
+@@ -27,7 +27,6 @@
+ PACKAGE_LDFLAGS += -L../libgpewidget
+ BUILD = ../build
+ else
+-PACKAGE_CFLAGS += -I/usr/include/gpe
+ BUILD = build
+ endif
+ PACKAGE_LDFLAGS += $(GPELIBS) $(GTKLDFLAGS)
diff --git a/recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch b/recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch
new file mode 100644
index 0000000000..01ceec10ea
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch
@@ -0,0 +1,27 @@
+Index: playlist_edit.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-nmf/playlist_edit.c,v
+retrieving revision 1.21
+retrieving revision 1.22
+diff -B -b -u -r1.21 -r1.22
+--- playlist_edit.c 8 Jul 2005 14:40:33 -0000 1.21
++++ playlist_edit.c 11 Jan 2006 23:23:32 -0000 1.22
+@@ -172,8 +172,16 @@
+
+ if (fe->current_path)
+ g_free(fe->current_path);
+- fe->current_path = isdir(s) ? g_strdup(s) : g_path_get_dirname (s);
+- strcat(fe->current_path,"/");
++ if (isdir (s))
++ {
++ fe->current_path = g_strdup_printf ("%s/", s);
++ }
++ else
++ {
++ gchar *dir = g_path_get_dirname (s);
++ fe->current_path = g_strdup_printf ("%s/", dir);
++ g_free (dir);
++ }
+
+ fe->fs_open = FALSE;
+