aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-nmf
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-nmf
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-nmf')
-rw-r--r--recipes/gpe-nmf/gpe-nmf-0.17/fix_makefiles.patch24
-rw-r--r--recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch15
-rw-r--r--recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch27
-rw-r--r--recipes/gpe-nmf/gpe-nmf.inc12
-rw-r--r--recipes/gpe-nmf/gpe-nmf_0.17.bb6
-rw-r--r--recipes/gpe-nmf/gpe-nmf_0.19.bb3
-rw-r--r--recipes/gpe-nmf/gpe-nmf_0.20.bb4
-rw-r--r--recipes/gpe-nmf/gpe-nmf_0.21.bb3
-rw-r--r--recipes/gpe-nmf/gpe-nmf_0.22.bb12
9 files changed, 106 insertions, 0 deletions
diff --git a/recipes/gpe-nmf/gpe-nmf-0.17/fix_makefiles.patch b/recipes/gpe-nmf/gpe-nmf-0.17/fix_makefiles.patch
new file mode 100644
index 0000000000..42b5c3628c
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf-0.17/fix_makefiles.patch
@@ -0,0 +1,24 @@
+diff -urNd ../gpe-nmf-0.17-r0/gpe-nmf-0.17/backend/Makefile gpe-nmf-0.17/backend/Makefile
+--- ../gpe-nmf-0.17-r0/gpe-nmf-0.17/backend/Makefile 2004-07-06 22:02:57.000000000 +0100
++++ gpe-nmf-0.17/backend/Makefile 2004-08-03 12:42:34.000000000 +0100
+@@ -48,7 +48,7 @@
+ clean:
+ rm -f $(DEPS) $(OBJS) $(OGG_OBJS) $(MAD_OBJS) $(BACKEND) d-vorbis.so d-mad.so
+
+-install_program: all
++install-program: all
+ mkdir -p $(DESTDIR)$(PREFIX)/lib
+ install -s $(BACKEND) $(DESTDIR)$(PREFIX)/lib/$(BACKEND)
+ for i in $(CODECS); do install -s $$i $(DESTDIR)$(PREFIX)/lib/gpe-nmf/decoders/$$i; done
+diff -urNd ../gpe-nmf-0.17-r0/gpe-nmf-0.17/Makefile gpe-nmf-0.17/Makefile
+--- ../gpe-nmf-0.17-r0/gpe-nmf-0.17/Makefile 2004-08-03 03:31:46.000000000 +0100
++++ gpe-nmf-0.17/Makefile 2004-08-03 12:37:33.000000000 +0100
+@@ -43,7 +43,7 @@
+ make -C backend PREFIX=$(PREFIX) GST=$(GST) GST_VERSION=$(GST_VERSION) CVSBUILD=$(CVSBUILD)
+
+ $(PACKAGE): $(OBJS) $(LIB)
+- $(CC) -o $@ $^ $(PACKAGE_LDFLAGS) -Lbackend -lgpenmf
++ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS) -Lbackend -lgpenmf
+
+ install-program: all $(PACKAGE).desktop
+ make -C backend PREFIX=$(PREFIX) DESTDIR=$(DESTDIR) install
diff --git a/recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch b/recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch
new file mode 100644
index 0000000000..cf6bd12da7
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf-0.22/fix-includepath.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- gpe-nmf-0.22/Makefile~fix-includepath
++++ gpe-nmf-0.22/Makefile
+@@ -27,7 +27,6 @@
+ PACKAGE_LDFLAGS += -L../libgpewidget
+ BUILD = ../build
+ else
+-PACKAGE_CFLAGS += -I/usr/include/gpe
+ BUILD = build
+ endif
+ PACKAGE_LDFLAGS += $(GPELIBS) $(GTKLDFLAGS)
diff --git a/recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch b/recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch
new file mode 100644
index 0000000000..01ceec10ea
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch
@@ -0,0 +1,27 @@
+Index: playlist_edit.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-nmf/playlist_edit.c,v
+retrieving revision 1.21
+retrieving revision 1.22
+diff -B -b -u -r1.21 -r1.22
+--- playlist_edit.c 8 Jul 2005 14:40:33 -0000 1.21
++++ playlist_edit.c 11 Jan 2006 23:23:32 -0000 1.22
+@@ -172,8 +172,16 @@
+
+ if (fe->current_path)
+ g_free(fe->current_path);
+- fe->current_path = isdir(s) ? g_strdup(s) : g_path_get_dirname (s);
+- strcat(fe->current_path,"/");
++ if (isdir (s))
++ {
++ fe->current_path = g_strdup_printf ("%s/", s);
++ }
++ else
++ {
++ gchar *dir = g_path_get_dirname (s);
++ fe->current_path = g_strdup_printf ("%s/", dir);
++ g_free (dir);
++ }
+
+ fe->fs_open = FALSE;
+
diff --git a/recipes/gpe-nmf/gpe-nmf.inc b/recipes/gpe-nmf/gpe-nmf.inc
new file mode 100644
index 0000000000..b7992e824a
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "GPE audio player"
+SECTION = "gpe/multimedia"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libgpewidget gstreamer gst-plugins"
+RDEPENDS = "esd gst-plugins gst-plugin-audio gst-plugin-audioconvert gst-plugin-audiofile gst-plugin-esd gst-plugin-typefindfunctions gst-plugin-volume"
+RRECOMMENDS = "gst-plugin-mad gst-plugin-tagedit"
+
+inherit gpe pkgconfig
+
+
+PARALLEL_MAKE=""
diff --git a/recipes/gpe-nmf/gpe-nmf_0.17.bb b/recipes/gpe-nmf/gpe-nmf_0.17.bb
new file mode 100644
index 0000000000..93fd043e63
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf_0.17.bb
@@ -0,0 +1,6 @@
+require gpe-nmf.inc
+
+RDEPENDS = ""
+RRECOMMENDS = ""
+
+SRC_URI += "file://fix_makefiles.patch;patch=1"
diff --git a/recipes/gpe-nmf/gpe-nmf_0.19.bb b/recipes/gpe-nmf/gpe-nmf_0.19.bb
new file mode 100644
index 0000000000..6ee24032e0
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf_0.19.bb
@@ -0,0 +1,3 @@
+require gpe-nmf.inc
+
+PR = "r4"
diff --git a/recipes/gpe-nmf/gpe-nmf_0.20.bb b/recipes/gpe-nmf/gpe-nmf_0.20.bb
new file mode 100644
index 0000000000..bfbb7a487c
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf_0.20.bb
@@ -0,0 +1,4 @@
+require gpe-nmf.inc
+
+RRECOMMENDS += "gst-plugin-tcp"
+PR = "r1"
diff --git a/recipes/gpe-nmf/gpe-nmf_0.21.bb b/recipes/gpe-nmf/gpe-nmf_0.21.bb
new file mode 100644
index 0000000000..f1292b93e2
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf_0.21.bb
@@ -0,0 +1,3 @@
+require gpe-nmf.inc
+
+RRECOMMENDS += "gst-plugin-tcp"
diff --git a/recipes/gpe-nmf/gpe-nmf_0.22.bb b/recipes/gpe-nmf/gpe-nmf_0.22.bb
new file mode 100644
index 0000000000..98b7683232
--- /dev/null
+++ b/recipes/gpe-nmf/gpe-nmf_0.22.bb
@@ -0,0 +1,12 @@
+require gpe-nmf.inc
+
+RDEPENDS += "gst-plugin-decodebin"
+RRECOMMENDS += "gst-plugin-ivorbis gst-plugin-tcp"
+PR = "r3"
+
+SRC_URI += " file://playlist-segfault.patch;patch=1;pnum=0 \
+ file://fix-includepath.patch;patch=1"
+
+do_compile() {
+ oe_runmake PREFIX=${prefix} GST_VERSION="0.8"
+}