aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-scap
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-scap
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-scap')
-rw-r--r--recipes/gpe-scap/gpe-scap-1.2/deviceinfo.patch22
-rw-r--r--recipes/gpe-scap/gpe-scap-1.3/allow-glade-2.4.0.patch26
-rw-r--r--recipes/gpe-scap/gpe-scap_1.2.bb15
-rw-r--r--recipes/gpe-scap/gpe-scap_1.3.bb15
-rw-r--r--recipes/gpe-scap/gpe-scap_1.4.bb13
-rw-r--r--recipes/gpe-scap/gpe-scap_svn.bb12
6 files changed, 103 insertions, 0 deletions
diff --git a/recipes/gpe-scap/gpe-scap-1.2/deviceinfo.patch b/recipes/gpe-scap/gpe-scap-1.2/deviceinfo.patch
new file mode 100644
index 0000000000..57e611d85e
--- /dev/null
+++ b/recipes/gpe-scap/gpe-scap-1.2/deviceinfo.patch
@@ -0,0 +1,22 @@
+Index: src/scr-shot-common.c
+===================================================================
+--- src/scr-shot-common.c (.../base/gpe-scap/src/scr-shot-common.c) (Revision 8890)
++++ src/scr-shot-common.c (.../extra/gpe-scap/src/scr-shot-common.c) (Arbeitskopie)
+@@ -37,7 +37,7 @@
+ gchar *
+ get_device_model (void)
+ {
+- gchar *result;
++ gchar *result = NULL;
+ struct utsname uinfo;
+ gchar **strv;
+ gint i = 0;
+@@ -62,6 +62,8 @@
+ }
+ g_strfreev (strv);
+ }
++ if (result)
++ return result;
+ #ifdef __arm__
+ result = g_strdup_printf ("%s,%s",_("ARM"), uinfo.machine);
+ #endif
diff --git a/recipes/gpe-scap/gpe-scap-1.3/allow-glade-2.4.0.patch b/recipes/gpe-scap/gpe-scap-1.3/allow-glade-2.4.0.patch
new file mode 100644
index 0000000000..766c5a51d9
--- /dev/null
+++ b/recipes/gpe-scap/gpe-scap-1.3/allow-glade-2.4.0.patch
@@ -0,0 +1,26 @@
+Index: gpe-scap-1.3/configure
+===================================================================
+--- gpe-scap-1.3.orig/configure 2008-01-17 17:01:49.000000000 +0100
++++ gpe-scap-1.3/configure 2008-01-17 17:03:01.000000000 +0100
+@@ -6327,7 +6327,7 @@
+
+
+
+-GLADE_MODULES="libglade-2.0 >= 2.4.2"
++GLADE_MODULES="libglade-2.0 >= 2.4.0"
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for GLADE" >&5
+Index: gpe-scap-1.3/configure.ac
+===================================================================
+--- gpe-scap-1.3.orig/configure.ac 2008-01-17 17:35:15.000000000 +0100
++++ gpe-scap-1.3/configure.ac 2008-01-17 17:35:20.000000000 +0100
+@@ -29,7 +29,7 @@
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+-GLADE_MODULES="libglade-2.0 >= 2.4.2"
++GLADE_MODULES="libglade-2.0 >= 2.4.0"
+ PKG_CHECK_MODULES(GLADE, $GLADE_MODULES)
+ AC_SUBST(GLADE_CFLAGS)
+ AC_SUBST(GLADE_LIBS)
diff --git a/recipes/gpe-scap/gpe-scap_1.2.bb b/recipes/gpe-scap/gpe-scap_1.2.bb
new file mode 100644
index 0000000000..1fc8f9a57a
--- /dev/null
+++ b/recipes/gpe-scap/gpe-scap_1.2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "GPE screenshot application"
+LICENSE = "GPL"
+PRIORITY = "optional"
+SECTION = "gpe"
+PR = "r1"
+
+RREPLACES = "gpe-screenshot"
+
+DEPENDS = "glib-2.0 gtk+ libgpewidget libglade libsoup"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
+
+SRC_URI += " file://deviceinfo.patch;patch=1;pnum=0"
diff --git a/recipes/gpe-scap/gpe-scap_1.3.bb b/recipes/gpe-scap/gpe-scap_1.3.bb
new file mode 100644
index 0000000000..6ac12c2a3c
--- /dev/null
+++ b/recipes/gpe-scap/gpe-scap_1.3.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A GPE application that allows you to take screenshots."
+LICENSE = "GPL"
+PRIORITY = "optional"
+SECTION = "gpe"
+PR = "r2"
+
+RREPLACES = "gpe-screenshot"
+
+DEPENDS = "glib-2.0 gtk+ libgpewidget libglade libsoup"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
+
+SRC_URI += " file://allow-glade-2.4.0.patch;patch=1"
diff --git a/recipes/gpe-scap/gpe-scap_1.4.bb b/recipes/gpe-scap/gpe-scap_1.4.bb
new file mode 100644
index 0000000000..03da9b02c3
--- /dev/null
+++ b/recipes/gpe-scap/gpe-scap_1.4.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "A GPE application that allows you to take screenshots."
+LICENSE = "GPL"
+PRIORITY = "optional"
+SECTION = "gpe"
+PR = "r0"
+
+RREPLACES = "gpe-screenshot"
+
+DEPENDS = "glib-2.0 gtk+ libgpewidget libglade libsoup"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
diff --git a/recipes/gpe-scap/gpe-scap_svn.bb b/recipes/gpe-scap/gpe-scap_svn.bb
new file mode 100644
index 0000000000..04010d7435
--- /dev/null
+++ b/recipes/gpe-scap/gpe-scap_svn.bb
@@ -0,0 +1,12 @@
+DEPENDS = "glib-2.0 gtk+ libgpewidget libglade libsoup"
+RREPLACES = "gpe-screenshot"
+PV = "1.4+svn-${SRCDATE}"
+PR = "r1"
+
+inherit autotools
+
+SRC_URI += "${GPE_EXTRA_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+DEFAULT_PREFERENCE = "-1"